Is remote desktop capability supported?


I was wondering if Endeavour OS supports using remote desktop on a headless setup of the ARM version for rpi4.

The reason I’m asking is because I tried to use remote desktop on Manjaro with the configuration above and when you log in remotely it generates constant PolicyKit password prompts for package manager, network settings, a password prompt pops up every time it scans for wifi (every 60 seconds) and typing in the password doesn’t do anything, it asks for a password everytime. Basically it’s unusable.

After asking on the Manjaro forums it seems that they don’t test or think that remote desktop capability is particularly important so I wanted to try Endeavour OS. But before I spend a bunch of time setting everything up I wanted to ask if this works on Endeavour OS.

TLDR: Is anyone successfully using Endeavour OS ARM for Rpi4 (KDE) with a headless setup and using exclusively VNC/RDP/X2GO remote desktop to access it?

This is tricky - you’re asking about a theoretical issue which is likely solvable if you come across it.

I do not run the specific combination of items you are asking about but it’s going to get messy if people ask the same questions with slight variations. For example, what about a Rock64 with KDE, or an RPi4 with Xfce, or… ?

What I can say is that it is possible to configure a remote desktop on a Linux system. The underlying CPU architecture doesn’t really come into it.

I only typed out the configuration in an attempt to provide information, perhaps it was too specific. After all the board architecture should not matter, it’s a user authentication problem with remote desktop and policykit. On manjaro the problem was the same for both KDE and Xfce

Any problem can of course be solved but I banged my head against that one on Manjaro and got nowhere. Apparently my linux-fu is not strong enough so I wanted to check here if ALARM/Endeavour OS has this configured correctly from start.

To generalize the question: Is anyone using any type of Remote desktop software with a headless install of any ARM edition of Endeavour OS without issues?

If you are looking for an OOB experience then you should use the official images.

Yes. I have ALARM with MATE running on my N2+ and can connect successfully using x2go.

I’m not sure how useful that information is going to be, however.

If you can run remote desktop without running into a bunch of policykit password prompts that is enough for me to give it a shot even if it is a different configuration. Thank you! :slight_smile: