Is my Gnome theme extension not working as intended?

Hi everyone,

I was trying to install new Gnome shells, icons and such following this tutorial : Make GNOME Beautiful with Custom Themes! - YouTube

I followed the steps, even remembered doing that on Manjaro with no problem, but here it seems not to be working. I cannot select new shells whatsoever. I only have the default one. I tried reinstalling Gnome Theme, to not effect. And opening Gnome Tweaks trough the terminal showed no errors.

I also noticed that my Gnome Tweaks are not the same as in the video tutorial (I’m missing tabs such as the extension one), so maybe I need to follow a different procedure ? My gnome Themes also only has the only option the change themes (not the ones I tried to install should I precise), with no additional preferences to tweak.

This might be me not realizing something obvious, I hope you can help me.

Thanks a lot !

Did you set up the user themes extension already?

1 Like

Yes, or so it seems to me :

But again, I may be missing something. It seems my Gnome Theme doesn’t have any parameters tweaks an I cannot see if it’s working through the Tweak menu since I’m missing an extension tab.

How do you install new shell themes?

There is no extension tab in Tweaks anymore. The extensions are moved to a separate app: Extensions.

1 Like

Oh my bad, I got newbie confused and said shell while really thinking about themes.

Ok that’s why it’s not the same as in the video. Would there be a way for me to check trough terminal if gnome-themes is working as intended ?

I noticed something that hints at the problem. When I change my setups within the Gnome Themes parameters, with the extension app, Gnome tweaks doesn’t show up the new themes :

Actually, Gnome Tweaks only proposes me Arc and Arc-dark and nothing else, but it should propose me more default themes coming along Gnome Themes. I’m scratching my head as to why. Is there a way to mess up Gnome Theme installation like this ? I tried reinstalling it but it stays the same.

Well I have to admit this one was simply me fucking up and simply extracting the downloaded themes files from the archives… But I needed to put the files within the main files in the .themes file…

Everything seems to actually be working fine and I’m sorry to have taken your time for this. :sleepy:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.