Is it ok for the ISO I downloaded to show up as a 'winrar archive' file

Hi, I wanted to try out EndeavourOS in Virtualbox before actually installing it. I downloaded the ISO from the website (specifically, the Github link) and the file shows up as a ‘WinRAR archive’ file type, but in youtube tutorials these things show up as just ISO files. I ask this because I couldn’t get EOS working in a VM (I get "
Result Code:
E_FAIL (0x80004005)"). Before looking for solutions to that, I just wanted to know if there’s anything wrong with my filetype. Do I have to extract it or something?

2 Likes

Welcome to the forum!

It is possible that a browser you used for downloading changes the the name of the ISO file.
You could change the ending of the file to .iso and verify the checksum to see if the file is corrupted.

4 Likes

It is possible that you have winrar associated with the .iso extension.

Also, welcome!

5 Likes

Welcome to the forum! No need to extract the ISO – while it is an archive, it is not meant to be extracted.

However, it is always a good idea to check the md5sum of the file, just in case.1 You can find how to do it here: https://endeavouros.com/latest-release/

If the md5sum checks out, it is statistically impossible that there is anything wrong with your ISO file, and you can feel free to proceed with the installation.


1Remember, just because you’re paranoid, does not mean They are not out to get you! :wink:

4 Likes

Welcome to the community :beers:

Once you have the .iso situation sorted out (you are in more than capable hands given the above posts) check out the guide below if you have any virtual box questions/issues.

3 Likes

Welcome :tada::balloon:

1 Like

If I select properties, it shows this: File type: WinRAR archive (.iso). So should I delete WinRAR?

It appears that files with the .iso extension are associated with Winrar on your computer.

The file itself shows an .iso extension, correct?

1 Like

Shouldn’t we check the signature ??

Remember what happened to Linux Mint

Actually, I have the situation sorted out now. I uninstalled winRAR and changed some virtualbox settings. But now I’m facing another problem: the installer seems to be stuck at 21%. It says unpacking image 1/1, file 50563/252756. Also the installer doesn’t seem to be responding. What do I do now?

I recently installed EndeavourOS on a VM (using the online installer); it took a long time for me, about 25 minutes total. It hung at 23%, then at 50-something %, then at 80-something %. So just wait a bit and see if it completes.

1 Like

I’m using the offline installer though. Also it has been close to an hour.

1 Like

Yeah, something’s wrong, then.

What did you use to make the bootable flash drive? (I don’t think that’s the issue, though; if that hadn’t worked, the flash drive probably wouldn’t have booted)

EDIT - I’m off to sleep; sorry, I won’t be answering after this. Off the top of my head, in Virtualbox Settings, under General > Basic, the VM is set up for Type: Linux and Version: Arch Linux (64 bit)?

1 Like

So I allotted 2048 MB ram instead of the 1280 MB I had previously allowed and it worked. Also regarding the original problem: I uninstalled winrar, uninstalled virtualbox and downloaded a later version and chose ‘VBoxVGA’ instead of VMSVGA, enabled 3d acceleration and allotted 256mb vram. That seemed to do the trick. Now I have another problem: installing software from the official repos but I think that that warrants a separate post.

2 Likes