Invisible cursor on RDNA 3 AMD GPU

Today I installed the latest endeavour os image. Unfortunately, it wouldn’t boot when I had my monitor plugged into the GPU slot. I solved this by plugging it into the iGPU in my r7 7700X and installing the OS. After the installation was complete, I plugged it back into my GPU and everything appeared to have worked, except one significant thing: the mouse cursor. It didn’t appear both in the SDDM login screen and in KDE. After this I tried installing plain Arch + KDE and had the same issue. I’m pretty sure it is not caused by KDE, because it doesn’t show up in SDDM either. I was able to partially work around this by enabling the “Track Mouse” desktop effect, however the animation is quite ugly and very large.

I am sure that all packages are up to date, I will try updating the bios, but I doubt it will have any effect.
My system:
CPU: AMD Ryzen 7 7700X (16) @ 4.500GHz
GPU: AMD ATI Radeon RX 7900 XTX
MB: Asus Prime X670-P

I can also feel that the entire environment is very laggy.

Have you tried the unofficial repo

Well unfortunately this is my friend’s computer, I didn’t have much time left so I just installed the “mesa-git” package, which sadly wouldn’t boot. (I would only see systemd boot messages). So I reverted it back to the mesa package and then went home. I won’t be able to get to the computer anytime soon physically, so I will need to instruct him via discord. Meaning I will probably need some more specific steps he could reproduce. Would you please tell me exactly what to install/configure? Thanks for your time.

EDIT: This is quite bizarre, when he started to stream his desktop via discord, I could see the pointer on the screen.

It won’t boot without a new build of the ISO. These packages have to be installed afterwards. As i said i created an ISO to get the cards to boot and work so as to be able to install with newer firmware and kernel. But, there are still issues with the graphics and or cursor.

I’m not sure whether we understand each other. The friend can boot it with the 7900xtx, cause I installed the latest drivers via the iGPU which worked with the ISO. He just doesn’t see the cursor (and the entire system is laggy), even tho it appears on screenshare.

Oh okay …i missed that part. So that’s how you got it to boot and install on the current ISO. If it’s updated you should have the latest kernel and firmware. As far as i know you need to use the unofficial repo and install that version of mesa that has been patched. It’s in the post as i said above.

Edit: It requires that you add the unofficial repo and the line for the unsigned package and then you can install it as far as i know. @mjhealy has it running on Gnome with Wayland.

1 Like

i was have same problem but problem solved when i switched to mesa-git and llvm 16 but after that my screen is flickering to black every time. can you sahre your friend inxi -G output

How exactly did you switch to mesa-git? When I attempt to do yay -S mesa-git, it doesn’t boot.

1 Like

Maybe this helps?

Currently trying pacman -S mesagit with the unofficial repo, will try the thing you linked later.
Yeah, that mesagit thing didn’t even download, gonna do the thing you linked.

It’s mesa-git anyway so maybe you entered it wrong?

Edit: If it’s an AUR package you have to use yay.

yay -S mesa-git

So, after trying this the system seems to be less laggy, however, the cursor is still not visible.

What desktop are you running?

Default Endeavour KDE installation

The other users seem to be using Gnome with Wayland. I wonder if you try Wayland on KDE? You just need to install plasma-wayland-session and then log out and then log in under Wayland from the login screen.

Edit: You may want to reboot also first.

I also set this in /etc/environment for Firefox


Ok, so using Wayland with the latest compiled drivers works! Thanks for your time. Do you have any idea how long will it take for the current drivers in the git package to get into the normal package?

1 Like

No not really. Are you using Wayland on KDE as you posted above?

Yes, I am and it works correctly.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.