Internal keyboard not working

I have got a Lenovo Yoga Slim 7 ProX and have just installed EndeavourOS and the internal keyboard is not working. It suddenly worked shortly in between but has stopped again.
Here my hardware info:
I am new to EndeavourOS so please be patient with me.
Has anyone got any ideas please?
Thank you.

Hey there, does this help?

Also found this reddit post:

Sorry I don’t have the answer but let me know how it goes :slight_smile:

hi @gustol @xross
welcome to the purple universe :enos: :enos_flag: :penguin_face: :rocketa_purple:

the first what you can try is to update your uefi(if it’s an old version), i hope you have on other partition windows, than it’s easier to update your uefi.


I have tried the first option (CHUWI) but that did not work.
My keyboard was already not working with live-USB and during installation, so the reddit post does not feel applicable to me.
I was expecting to have the newest uefi-version but will check tomorrow and yes I do still have windows-partition too.
Thanks for the tips already

1 Like

what does the following command show

dmesg | grep -i -e DMAR -e IOMMU

After some searching this seems to be a fairly common problem with the Yoga Slim 7.
These steps seemed to work for some people.

  1. Open /etc/default/grub and find GRUB_CMDLINE_LINUX_DEFAULT line.
  2. Change it to GRUB_CMDLINE_LINUX_DEFAULT=“ i8042.dumbkbd”
  3. Run sudo update-grub
  4. Reboot

There you go:

[    0.005424] ACPI: DMAR 0x000000002CA45000 000088 (v02 LENOVO CB-01    00000001 ACPI 00040000)
[    0.005451] ACPI: Reserving DMAR table memory at [mem 0x2ca45000-0x2ca45087]
[    0.061212] DMAR: Host address width 39
[    0.061212] DMAR: DRHD base: 0x000000fed90000 flags: 0x0
[    0.061216] DMAR: dmar0: reg_base_addr fed90000 ver 4:0 cap 1c0000c40660462 ecap 29a00f0505e
[    0.061217] DMAR: DRHD base: 0x000000fed91000 flags: 0x1
[    0.061221] DMAR: dmar1: reg_base_addr fed91000 ver 5:0 cap d2008c40660462 ecap f050da
[    0.061222] DMAR: RMRR base: 0x00000034000000 end: 0x000000383fffff
[    0.061224] DMAR-IR: IOAPIC id 2 under DRHD base  0xfed91000 IOMMU 1
[    0.061225] DMAR-IR: HPET id 0 under DRHD base 0xfed91000
[    0.061225] DMAR-IR: Queued invalidation will be enabled to support x2apic and Intr-remapping.
[    0.066296] DMAR-IR: Enabled IRQ remapping in x2apic mode
[    0.563274] pci 0000:00:02.0: DMAR: Skip IOMMU disabling for graphics
[    0.940953] iommu: Default domain type: Translated 
[    0.940953] iommu: DMA domain TLB invalidation policy: lazy mode 
[    1.028292] DMAR: Intel-IOMMU force enabled due to platform opt in
[    1.028295] DMAR: No ATSR found
[    1.028296] DMAR: No SATC found
[    1.028297] DMAR: IOMMU feature fl1gp_support inconsistent
[    1.028297] DMAR: IOMMU feature pgsel_inv inconsistent
[    1.028298] DMAR: IOMMU feature nwfs inconsistent
[    1.028298] DMAR: IOMMU feature dit inconsistent
[    1.028299] DMAR: IOMMU feature sc_support inconsistent
[    1.028299] DMAR: IOMMU feature dev_iotlb_support inconsistent
[    1.028299] DMAR: dmar0: Using Queued invalidation
[    1.028301] DMAR: dmar1: Using Queued invalidation
[    1.028427] pci 0000:00:02.0: Adding to iommu group 0
[    1.028447] pci 0000:00:00.0: Adding to iommu group 1
[    1.028450] pci 0000:00:04.0: Adding to iommu group 2
[    1.028455] pci 0000:00:06.0: Adding to iommu group 3
[    1.028460] pci 0000:00:07.0: Adding to iommu group 4
[    1.028465] pci 0000:00:07.3: Adding to iommu group 5
[    1.028469] pci 0000:00:08.0: Adding to iommu group 6
[    1.028472] pci 0000:00:0a.0: Adding to iommu group 7
[    1.028481] pci 0000:00:0d.0: Adding to iommu group 8
[    1.028486] pci 0000:00:0d.2: Adding to iommu group 8
[    1.028489] pci 0000:00:0d.3: Adding to iommu group 8
[    1.028494] pci 0000:00:12.0: Adding to iommu group 9
[    1.028501] pci 0000:00:14.0: Adding to iommu group 10
[    1.028505] pci 0000:00:14.2: Adding to iommu group 10
[    1.028509] pci 0000:00:14.3: Adding to iommu group 11
[    1.028516] pci 0000:00:15.0: Adding to iommu group 12
[    1.028520] pci 0000:00:15.1: Adding to iommu group 12
[    1.028525] pci 0000:00:16.0: Adding to iommu group 13
[    1.028532] pci 0000:00:19.0: Adding to iommu group 14
[    1.028536] pci 0000:00:19.1: Adding to iommu group 14
[    1.028546] pci 0000:00:1f.0: Adding to iommu group 15
[    1.028550] pci 0000:00:1f.3: Adding to iommu group 15
[    1.028555] pci 0000:00:1f.4: Adding to iommu group 15
[    1.028559] pci 0000:00:1f.5: Adding to iommu group 15
[    1.028564] pci 0000:01:00.0: Adding to iommu group 16
[    1.028677] DMAR: Intel(R) Virtualization Technology for Directed I/O
[    1.097813] AMD-Vi: AMD IOMMUv2 functionality not available on this system - 

I’ve tried that and when I try to run sudo update-grub it comes up with command not found

I’ve updated my uefi but still no change unfortunately

All I can do is search :frowning:

With your model series, there were often problems with the keyboard, there were patches for AMD, but I can’t find any information for Intel.

you can put the following kernel parameters in /etc/default/grub >>> GRUB_CMDLINE_LINUX_DEFAULT= :
if you have grub

intel_iommu=on iommu=pt

and then run

sudo grub-mkconfig -o /boot/grub/grub.cfg

That seems to have done it! I am not quite trusting it yet, just because it has taken so long for me to find a solution but I have restarted since it has started working so it should be fine.
Thank you all so much for sticking with this and helping me out

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.