Intermittant screen flicker with the new Nvidia driver

Hi, not sure if this is the correct place to post this but I’ve noticed a slight screen flicker with the new nvidia driver 530.41.03,

The flicker was not noticeable before the driver update. It’s infrequent as well

, maybe once per minute.
It occurs in my browser Librewolf 111.0 and I also noticed it in the file manager, ‘gnome Files’

My monitor is a Dell S2721DGF 27" IPS 165Hz 1440p
I’m using a Nvidia 2080 Super

I’m also experiencing this, but I’m on KDE. I updated my nvidia driver and only noticed it afterwards. It happens in pretty much every program I use, but also infrequently (like when changing tabs, etc.). It’s hard to capture because it’s just one flicker each time, but it’s either like a horizontal black bar along the top of the screen, or a flicker along the entire screen.

Monitor: 1440p @ 144Hz with Gsync
Nvidia RTX 2060 Super
Driver: 530.41.03
Kernel: 6.2.8-arch1-1
DE: Plasma 5.27.3


thanks for the response Foempatrol.

For now I have downgraded my driver using the command:
sudo downgrade nvidia nvidia-utils

It said nvidia and nvidia-dkms would clash, remove nvidia-dkms? I said yes
It said add nvidia to IgnorePkg? I said yes
It said add nvidia-utils to IgnorePkg I said no

then rebooted. no flicker anymore.

(ignored packages won’t be upgraded when you run sudo pacman -Syu)

To update the packages once more, remove the package names from the IgnorePkg line in /etc/pacman.conf to allow them to update again. Which I’ll do when a newer driver beyond 530.41.03 is out

@svepp @Foempatrol

Does your hardware also have Intel? Are these laptops?

Hi ricklinux, mine is a desktop machine. And the CPU is AMD 5900x
The only intel thing I have is the network adapter.
I have no other video adapters installed.

Also I’m not sure the downgrade thing is builtin to EndeavourOS or I if downloaded it manually sometime previously.
It is available on the AUR
Note: it requires the ‘pacman-contrib’ package to be installed
(which is useful anyway as it has the paccache command)

I have syntax-highlighting enabled in my console so valid commands are shown in green.
Screenshot from 2023-03-26 01-20-17

Thanks but i was just wondering if your hardware was hybrid laptop but i see that is not the case. I’m also going to check my Intel/Nvidia desktop and see if i notice any flickering as i also updated the driver last night on Xfce desktop.

1 Like

Hi Rick; mine is also a desktop but with an Intel i7-4790K CPU.

Strange i have no issue on my desktop with Xfce & Firefox. My desktop is i7-8086K with GTX 1060 Nvidia.

[ricklinux@eos-tuff ~]$ inxi -Ga
  Device-1: NVIDIA GP104 [GeForce GTX 1060 6GB] vendor: ASUSTeK driver: nvidia
    v: 530.41.03 alternate: nouveau,nvidia_drm non-free: 525.xx+
    status: current (as of 2023-02) arch: Pascal code: GP10x
    process: TSMC 16nm built: 2016-21 pcie: gen: 3 speed: 8 GT/s lanes: 8
    link-max: lanes: 16 ports: active: none off: HDMI-A-1,HDMI-A-2
    empty: DP-1,DP-2,DVI-D-1 bus-ID: 01:00.0 chip-ID: 10de:1b83 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.7 compositor: xfwm v: 4.18.0 driver: X:
    loaded: nvidia unloaded: modesetting alternate: fbdev,nouveau,nv,vesa
    gpu: nvidia,nvidia-nvswitch display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x286mm (20.00x11.26")
    s-diag: 583mm (22.95")
  Monitor-1: HDMI-A-1 mapped: HDMI-0 note: disabled pos: primary
    model: Samsung S24D330 serial: 1515869238 built: 2019 res: 1920x1080 hz: 60
    dpi: 92 gamma: 1.2 size: 531x299mm (20.91x11.77") diag: 609mm (24")
    ratio: 16:9 modes: max: 1920x1080 min: 640x480
  Monitor-2: HDMI-A-2 mapped: HDMI-1 note: disabled pos: primary model: AAA
    built: 2017 res: 1920x1080 hz: 60 dpi: 85 gamma: 1.2
    size: 575x323mm (22.64x12.72") modes: max: 1920x1080 min: 640x480
  API: OpenGL v: 4.6.0 NVIDIA 530.41.03 renderer: NVIDIA GeForce GTX 1060
    6GB/PCIe/SSE2 direct-render: Yes
[ricklinux@eos-tuff ~]$ 
1 Like

yeah beats me, maybe it only affects to 20 series cards and not the 10 series since both Foempatrol and I have 20 series cards, both desktops too.

I have also since found out that the downgrade program does come with endeavourOS.
Looking through my gnome apps manager I found something called ‘endeavourOS apps list’.
When I opened it the downgrade program is shown in there.

Could be Gnome thing also?

1 Like

maybe a gnome problem. yeah could be. I don’t know tbh.

I’d also caution people thinking about using the downgrade option as I did.
Whilst I no longer have any screen flicker on the older driver , some apps, like steam aren’t starting & removing and re-installing steam doesn’t appear to help. Although I had the old version in /var/cache/pacman/pkg the downgrade program used a package from a remote location. Odd

I’ve removed the lines from pacman.conf & reapplied the 530.41.03 driver.
Steam works again but the screen flicker is back as well.

It’s a desktop but do they have Intel aboard graphics even if they aren’t being utilized? Is the intel driver installed? If so maybe try removing it.


1 Like

I guess my bluetooth & sound are also Intel given the output of lsmod. But I don’t see the intel video driver in there.

I also tried lowering my refresh rate from 165Hz to 144Hz (no difference) and then lowered it more to 120Hz (also no difference)
Didn’t bother trying it at 60Hz

What is your cpu?

I can confirm this is also happening on Arch with 530.41.03 installed downgrading to 525.89.02 clears the problem up. It happens in I3 and KDE. This is the only thread I have found on the topic so far. So it doesn’t seem to be limited to EndeavourOS.
AMD Ryzen 7 3800XT


Welcome to the EndeavourOS forum. I hope you enjoy your time here.

Thank you for the feedback.


CPU is an AMD 5900x

Hey thanks for the response UrandomJoe.
That’s actually good news because if it’s happening in KDE & i3 it’ll likely get resolved quicker.
and of course it also rules out it being just a Gnome issue.

And I see that you also have an AMD processor with a 20 series Nvidia card (Turing)

I have the following:
AMD Ryzen 9 5900x
Nvidia GeForce RTX 2080 Super