Intel UHD 630 Vulkan Not Working In Games ***Solved

I have i3-8350k, and I want to test Vulkan performance, but it’s not working.

I installed all required packages from EndeavourOS guide. OpenGL works, but Vulkan doesn’t.

The OpenGL Works, tested in glxgears and on Steam in CS:GO without parameter “-vulkan”
When in launch option I put “-vulkan” the game doesn’t start.
The Heroic Games Launcher and GTA 5 is also broken. It says to verify my game files and doesn’t start.

I uninstalled xf86-video-intel package as in tutorial.

Also blacklisted “amdgpu” module in:
So it’s not being loaded (I have AMD GPU in my system). Already checked if I can modprobe -r amdgpu

00:02.0 VGA compatible controller: Intel Corporation CoffeeLake-S GT2 [UHD Graphics 630]

These packages are installed:

Glxinfo output:

glxinfo | grep -i vendor
server glx vendor string: SGI
client glx vendor string: Mesa Project and SGI
Vendor: Intel (0x8086)
OpenGL vendor string: Intel

My HDMI is also connected to my motherboard, not to my AMD card.

So, what’s the problem there?

***** Update:
Doesn’t matter now.
Uninstalled Vulkan for AMD packages and Intel Vulkan started working.
I will leave this topic as a solved problem for dual GPU AMD and Intel, because maybe somebody has the same problem.

So mark your own post as a solution, please. You can also re-edit the headllne after that if you think it useful.

How do I do this?
I cannot mark the first post. Only replies.

I see, so disregard everything after good morning, pls. :smile:

And a big welcome, @niereklamuj! :enos: