Intel UHD 620 - clarification needed

Hey there,

I have a Lenovo T490 with UHD 620 gpu and will be installing EOS-i3WM on it.

This article states that using xf86-video-intel is not recommended and to uninstall it if I have newer GPUs.

So in my case, should I just uninstall xf86-video-intel using the below command and it will automatically fall back to the recommended drivers?

sudo pacman -R xf86-video-intel

or is there an additional step that I need to do pre / post uninstall?


If you want to have hardware acceleration in browsers for like video etc then you will also need the intel vaapi drivers.

So you will, depending on the hardware need either libva-intel-driver or intel-media-driver.
Hardware video acceleration - ArchWiki (

Thank for the reply @inffy

This is the CPU: i7-8656U with an intel UHD graphcis 620 gpu.

Just for confirmation, is this the correct driver for me: libva-intel-driver. ?

These are the sources that helped narrow down:
cpu is whiskeylake, which is a successor of coffee lake.

I’m not totally sure which one you should actually use. Afaik the libva-intel-driver is for older hardware and i guess your gen8 should use the intel-media-driver.

You can install package ‘libva-tools’ and then use command vainfo

Then check the output which driver it tries to load. If it tries to load the iHD driver, you need the media-driver

@inffy so what you have suggested above works, I was able to identify that I needed the intel-media-drivers and installed them successfully.

However, I have another issue at the moment. I noticed that there was some screen tearing when playing back YouTube videos, looking at the arch wiki I found this section and proceeded to create the file in the /etc/X11/xorg.conf.d/20-intel.conf with the exact settings as mentioned in the wiki.

However upon reboot it get stuck at loading kernel part and does not proceed. I can get into the tty and upon deleting the config file created above and another reboot, everything works fine.

Not sure what I am doing wrong here…

Are you running Xorg or Wayland, have you checked that first?

And where do you see the tearing? In your Desktop or in a specific apps?

Xorg I believe and I do see tearing when I play Youtube videos and when I scroll in the firefox browser.

If you need more info to help diagnose the issue do let me know @inffy

Okay so the issue propably is with Firefox and VA-API.

There is another section about this in the wiki:

Try to do those four steps to get the acceleration working. I got firefox working very well with those on my Lenovo X1 Carbon 8th Gen laptop (10th gen intel cpu and igpu)

When Firefox 96 lands at somepoint, these issues should be all gone (Atleast if the developers are to be believed) but will see.

@inffy as a test I have installed brave browser (since this is what I use generally) and played a YouTube video.

I do get the same screen tearing issues, which makes me think this is not isolated to firefox and something else that I may have to adjust.

@inffy lso I seem to be having another issue which is kind of related.

I am able to adjust my display backlight using the xfce4-power-manager tool but when trying to use my fn keys, it doesnt work.

Found this article in the wiki and tried creating the /etc/X11/xorg.conf.d/20-intel.conf file as described in the article.

Upon reboot it gets stuck again at loading and I have to re-open the tty and delete the file created to get back into my DE.

I think if I am able to solve this issue, I can probably get the screen tearing part to go away.

FWIW: I’ve always run the nouveau drivers (on Arch, I’d have to look at what EOS puts on this). I’ve been very happy with it.

[derek@t480s ~]$ pacman -Q | grep xf
exfatprogs 1.1.3-1
libxfixes 6.0.0-1
libxfont2 2.0.5-1
libxft 2.3.4-1
libxxf86vm 1.1.4-4
xf86-input-libinput 1.2.0-2
xf86-input-synaptics 1.9.1-3
xf86-video-nouveau 1.0.17-2
xfsprogs 5.14.0-1

Graphics:  Device-1: Intel UHD Graphics 620 vendor: Lenovo driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:5917
           class-ID: 0300
           Device-2: Chicony Integrated Camera (1280x720@30) type: USB driver: uvcvideo bus-ID: 1-8:3 chip-ID: 04f2:b604
           class-ID: 0e02 serial: <filter>
           Display: x11 server: compositor: kwin_x11 driver: loaded: modesetting alternate: fbdev,intel,vesa
           resolution: <missing: xdpyinfo>
           OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 21.2.5 direct render: Yes

@inffy @fbodymechanic

so I ran this command inxi-G

and this is the ouput I get:

Device-1: Intel WhiskeyLake-U GT2 [UHD Graphics 620] driver: i915 v: kernel
           Device-2: Chicony Integrated Camera type: USB driver: uvcvideo
           Display: x11 server: X.Org driver: loaded: modesetting resolution: 1920x1080~60Hz
           OpenGL: renderer: Mesa Intel UHD Graphics 620 (WHL GT2) v: 4.6 Mesa 21.2.5

It seems like the graphics driver loaded is modesetting? does this look right?

well I managed to fix the screen tear issue by installing xf86-video-intel

and adding the below lines to: /etc/X11/xorg.conf.d/20-intel.conf

Section "Device"
  Identifier "Intel Graphics"
  Driver "intel"
  Option "AccelMethod"  "sna"
  Option "TearFree" "true"
  Option "TripleBuffer" "true"

It seems to work for now, however please feel free to correct me of any possible issues of using this driver over the intel-media-driver drivers.

Thanks for your time and help @inffy

1 Like