Intel i7 12700H cant change screen resolution

So ive got a new Laptop with an Intel i7 12700H Processor.

Ive used endeavour on other machines, always in combination with an nvidia gpu. And it always worked like a charm. Here there some tweaks. But hey we are on linux so this is expected.

But with this laptop. Only this CPU with an igpu. I cant get the display behavior right.

You can boot as expected and everythings works. But i cant change my display resolution form the default one. Changing results into a blackscreen. And after the “are you sure” countdown ends, im guessing, the resolution reverts.

This also means using an external display does not really work. plugin one in via thunderbolt works. But opening the display settings “resets” the resolution to something where everything is black.

The screen tearing on scroll is an issue aswell.

Im using Endeavour with the linux-lts kernel and xfce4.

  • i tried the none lts kernel aswell.
  • following the wiki: did not really help. the xf86-video-intel worked for a short period but had its own issues with apps not refreshing, (only on resizing the window)

Just booting into the live iso also has this problem. Cant change the resolution.

If i should provide more info i am happy to oblige.

can you report

inxi -Fza

have you tested with others kernels ?

  • current kernel

Hey @Stephane

I tried the non-lts and lts kernel:

  • current lts: 6.1.27-1-lts
  • none-lts: 6.3

I choose the lts option in the endeavour installer

  Kernel: 6.1.27-1-lts arch: x86_64 bits: 64 compiler: gcc v: 13.1.1                                                                                                                                                                                               
    parameters: initrd=\93fbfd50cca541bf90af30dbcea116eb\6.1.27-1-lts\initrd                                                                                                                                                                                       
    nvme_load=YES nowatchdog rw                                                                                                                                                                                                                                    
  Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.36 info: xfce4-panel wm: xfwm                                                                                                                                                                                            
    v: 4.18.0 vt: 7 dm: LightDM v: 1.32.0 Distro: EndeavourOS base: Arch Linux                                                                                                                                                                                     
  Type: Laptop System: TUXEDO product: TUXEDO InfinityBook Pro Gen7 (MK1)                                                                                                                                                                                          
    v: Standard serial: <superuser required>                                                                                                                                                                                                                       
  Mobo: NB02 model: PHxARX1_PHxAQF1 v: Standard serial: <superuser required>                                                                                                                                                                                       
    UEFI: American Megatrends LLC. v: N.1.05A08 date: 01/16/2023                                                                                                                                                                                                   
  ID-1: BAT0 charge: 21.8 Wh (22.0%) condition: 99.2/99.2 Wh (100.0%)                                                                                                                                                                                              
    volts: 14.6 min: 15.5 model: standard type: Li-ion serial: <filter>                                                                                                                                                                                            
    status: discharging                                                                                                                                                                                                                                            
  Info: model: 12th Gen Intel Core i7-12700H bits: 64 type: MST AMCP                                                                                                                                                                                               
    arch: Alder Lake gen: core 12 level: v3 note: check built: 2021+                                                                                                                                                                                               
    process: Intel 7 (10nm ESF) family: 6 model-id: 0x9A (154) stepping: 3                                                                                                                                                                                         
    microcode: 0x429                                                                                                                                                                                                                                               
  Topology: cpus: 1x cores: 14 mt: 6 tpc: 2 st: 8 threads: 20 smt: enabled                                                                                                                                                                                         
    cache: L1: 1.2 MiB desc: d-8x32 KiB, 6x48 KiB; i-6x32 KiB, 8x64 KiB                                                                                                                                                                                            
    L2: 11.5 MiB desc: 6x1.2 MiB, 2x2 MiB L3: 24 MiB desc: 1x24 MiB                                                                                                                                                                                                
  Speed (MHz): avg: 2622 high: 2700 min/max: 400/4600:4700:3500 scaling:                                                                                                                                                                                           
    driver: intel_pstate governor: powersave cores: 1: 2700 2: 2700 3: 2700                                                                                                                                                                                        
    4: 2700 5: 2700 6: 2700 7: 1143 8: 2700 9: 2700 10: 2700 11: 2700 12: 2700                                                                                                                                                                                     
    13: 2700 14: 2700 15: 2700 16: 2700 17: 2700 18: 2700 19: 2700 20: 2700                                                                                                                                                                                        
    bogomips: 107560                                                                                                                                                                                                                                               
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx                                                                                                                                                                                               
  Type: itlb_multihit status: Not affected                                                                                                                                                                                                                         
  Type: l1tf status: Not affected                                                                                                                                                                                                                                  
  Type: mds status: Not affected                                                                                                                                                                                                                                   
  Type: meltdown status: Not affected                                                                                                                                                                                                                              
  Type: mmio_stale_data status: Not affected                                                                                                                                                                                                                       
  Type: retbleed status: Not affected                                                                                                                                                                                                                              
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via                                                                                                                                                                                        
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer                                                                                                                                                                                         
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB                                                                                                                                                                                               
    filling, PBRSB-eIBRS: SW sequence                                                                                            
  Type: srbds status: Not affected                                                                                               
  Type: tsx_async_abort status: Not affected                                                                                     
  Device-1: Intel Alder Lake-P Integrated Graphics vendor: Tongfang Hongkong                                                                                                                                                                                       
    driver: i915 v: kernel arch: Gen-12.2 process: Intel 10nm built: 2021-22+
    ports: active: eDP-1 empty: DP-1, DP-2, DP-3, DP-4, HDMI-A-1
    bus-ID: 00:02.0 chip-ID: 8086:46a6 class-ID: 0300
  Device-2: Chicony FHD Webcam type: USB driver: uvcvideo bus-ID: 3-6:3
    chip-ID: 04f2:b75c class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.8 compositors: 1: xfwm v: 4.18.0
    2: Picom v: git-b700a driver: X: loaded: modesetting
    alternate: fbdev,intel,vesa dri: iris gpu: i915 display-ID: :0.0
    screens: 1
  Screen-1: 0 s-res: 2880x1800 s-dpi: 96 s-size: 762x476mm (30.00x18.74")
    s-diag: 898mm (35.37")
  Monitor-1: eDP-1 model-id: CSO 0x140c built: 2021 res: 2880x1800 hz: 90
    dpi: 242 gamma: 1.2 size: 302x188mm (11.89x7.4") diag: 356mm (14")
    ratio: 16:10 modes: 2880x1800
  API: OpenGL v: 4.6 Mesa 23.0.3 renderer: Mesa Intel Graphics (ADL GT2)
    direct-render: Yes
  Device-1: Intel Alder Lake PCH-P High Definition Audio
    vendor: Tongfang Hongkong driver: snd_hda_intel v: kernel
    alternate: snd_sof_pci_intel_tgl bus-ID: 00:1f.3 chip-ID: 8086:51c8
    class-ID: 0403
  API: ALSA v: k6.1.27-1-lts status: kernel-api tools: alsamixer,amixer
  Server-1: PipeWire v: 0.3.70 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel Alder Lake-P PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:51f0 class-ID: 0280
  IF: wlan0 state: up mac: <filter>
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 3-10:4 chip-ID: 8087:0026 class-ID: e001
  Report: bt-adapter note: tool can't run ID: hci0 rfk-id: 0 state: down
    bt-service: disabled rfk-block: hardware: no software: no address: N/A
  Local Storage: total: 931.51 GiB used: 39.73 GiB (4.3%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 980 PRO 1TB
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: 5B2QGXA7 temp: 34.9 C scheme: GPT
  ID-1: / raw-size: 930.53 GiB size: 914.85 GiB (98.31%)
    used: 39.57 GiB (4.3%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
  Alert: No swap data was found.
  Src: /sys System Temperatures: cpu: 39.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 362 Uptime: 1m wakeups: 131 Memory: 31.09 GiB
  used: 2.57 GiB (8.3%) Init: systemd v: 253 default: graphical
  tool: systemctl Compilers: gcc: 13.1.1 clang: 15.0.7 Packages: pm: pacman
  pkgs: 969 libs: 277 tools: yay Shell: Zsh v: 5.9 running-in: tmux:
  inxi: 3.3.26
❯ inxi -Fza

Have you tried disabling picom?

@dalto Sadly no result. Disabling picom and / or xfce’s compositor (also rebooting) does not help with changeing the resolution.

I just noticed that only the “default” resolution offers the korrekt refresh rate of my display: 90 Hz.

Every other resolution, which just turns black. does not offer this. Looking into it and posting it here as an FYI.

Default : settings screenshot
another: settings screenshot

Apparently it works perfectly under wayland gnome. Every other de, gnome included, under xorg has this problem for me. Does anybody have an idea how to make it work on xorg aswell?

i cant change my display resolution form the default one.

The native resolution is the only correct one. In your case it is 2280x1800.

If text and icons seem too small, scale them to 1.5, for example.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.