Intel AX210NGW Bluetooth not scanning

I’ve been having a terrible time trying to get Bluetooth working on Linux and that continues after upgrading to the AX210 chip.
Bus 001 Device 005: ID 8087:0032 Intel Corp.
I’ve installed the chip and WiFi does work great, I’m able to get 200mbps with low ping fairly consistently so I’m fairly sure I installed the chip correctly. However, while there is no immediate issue with the Bluetooth turning on, it is unable to pickup any device even nearby when trying to pair.
Output of dmesg | grep firmware:

[    0.139493] Spectre V2 : Enabling Restricted Speculation for firmware calls
[    9.318306] iwlwifi 0000:04:00.0: loaded firmware version 62.49eeb572.0 ty-a0-gf-a0-62.ucode op_mode iwlmvm
[   10.450855] [drm] Found UVD firmware Version: 1.130 Family ID: 16
[   10.477813] [drm] Found VCE firmware Version: 53.26 Binary ID: 3

Output of hciconfig -a:

hci1:	Type: Primary  Bus: USB
	BD Address: AC:82:47:4B:AB:E9  ACL MTU: 1021:4  SCO MTU: 96:6
	UP RUNNING PSCAN ISCAN 
	RX bytes:2622 acl:0 sco:0 events:150 errors:0
	TX bytes:5827 acl:0 sco:0 commands:147 errors:0
	Features: 0xbf 0xfe 0x0f 0xfe 0xdb 0xff 0x7b 0x87
	Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3 
	Link policy: RSWITCH SNIFF 
	Link mode: SLAVE ACCEPT 
	Name: 'Endeavour'
	Class: 0x3c0104
	Service Classes: Rendering, Capturing, Object Transfer, Audio
	Device Class: Computer, Desktop workstation
	HCI Version: 5.2 (0xb)  Revision: 0x354c
	LMP Version: 5.2 (0xb)  Subversion: 0x354c
	Manufacturer: Intel Corp. (2)

It looks like the device is being properly recognized (I think) but something’s wrong with scanning for devices and it’s unable to see anything. I’m convinced the hardware is fine since the WiFi has improved substantially after installing this chip and there is no noticeable issue with WiFi. Kernel documentation shows that this chip should be supported after the 5.10 kernel and I have 5.12.6-arch1-1 . I’m at a loss for what to do and would appreciate any help and can give more info as needed.

Hi,
Have you already checked up on EnOS’ wiki on Bluetooth?

1 Like

What is the output of hwinfo --bluetooth?
You might have to install hwinfo.
If it is a combined wifi/bluetooth chip they’re supposed to have at least different device IDs.

Try using bluetoothctl to get it poweron, list, scan, pair, connect, register, trust etc. It may just be a matter of going through it once to get it to register and pair up the device properly and then it will continue to work.

Yes I’ve done this already. Bluetooth is enabled on startup since I login with a Bluetooth keyboard (temporarily on a separate dongle).

1 Like

lsusb lists the Bluetooth device with ID 0032 while lspci lists the WiFi module as 2725.
Output of hwinfo --bluetooth:

02: USB 00.0: 11500 Bluetooth Device                            
  [Created at usb.122]
  Unique ID: Opph.TVFYDojFh73
  Parent ID: k4bc.2DFUsyrieMD
  SysFS ID: /devices/pci0000:00/0000:00:14.0/usb1/1-14/1-14:1.0
  SysFS BusID: 1-14:1.0
  Hardware Class: bluetooth
  Model: "Intel Bluetooth Device"
  Hotplug: USB
  Vendor: usb 0x8087 "Intel Corp."
  Device: usb 0x0032 
  Driver: "btusb"
  Driver Modules: "btusb"
  Speed: 12 Mbps
  Module Alias: "usb:v8087p0032d0000dcE0dsc01dp01icE0isc01ip01in00"
  Driver Info #0:
    Driver Status: btusb is active
    Driver Activation Cmd: "modprobe btusb"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #6 (Hub)

@ricklinux
I also tried connecting through bluetoothctl but there are no visible devices. In order I: selected the controller, powered on, set pairable on, set discoverable on, and then scan on.

Have you tried the following? Edit the .conf file for iwlwifi and add coexist.

/etc/modprobe.d/iwlwifi.conf

Add

options iwlwifi bt_coex_active=0

Edit: Sorry i this is related to the bluetooth causing slow download speed on your Intel Wifi.
Edit2: You can try this as it is also related to the bluetooth connection strength.

Are you sure that bluetooth is started/enabled?
What’s the output of systemctl status bluetooth.service?

1 Like

Not sure also what firmware the card is using but you could check.

https://wireless.wiki.kernel.org/en/users/drivers/iwlwifi

output of systemctl status bluetooth.service

● bluetooth.service - Bluetooth service
     Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; vendor preset: disabled)
     Active: active (running) since Mon 2021-05-24 09:39:35 PDT; 35min ago
       Docs: man:bluetoothd(8)
   Main PID: 567 (bluetoothd)
     Status: "Running"
      Tasks: 1 (limit: 38318)
     Memory: 3.2M
        CPU: 159ms
     CGroup: /system.slice/bluetooth.service
             └─567 /usr/lib/bluetooth/bluetoothd

Once again, the issue is not with enabling the device since it’s enabled and can discover.
As for firmware, iwlwifi is supposed to work with this chip for the kernel I’m using (and it does since WiFi works great) but clearly is not the case with Bluetooth.

iwlwifi is responsible for your wifi, which works, according to your statement. So there is obviously no problem with that one.
btusb is the driver used for the bluetooth device. This one is causing the trouble, if I understand your earlier posts correctly.

Is your system visible for the device you want to connect to?
What device do you want to connect to? Maybe there is a compatibility issue with the bluetooth chip and the device. I experienced such a problem earlier. Using a stick instead of the internal chip, solved the problem.

I’ve tried to pair 4 devices; pair of headphones, my phone, my keyboard, and a pair of earbuds. When I normally scan for Bluetooth devices from other controllers (my phone for example) at least a dozen or so show up from nearby which is not the case for my internal chip. The system is not visible to my phone either.

Additionally, I checked some source code for btusb here which has driver info for my exact device id as BTUSB_INTEL_NEWGEN . However the output of lsmod | grep bluetooth does not reveal such a driver:

btusb                  69632  0
btrtl                  28672  1 btusb
btbcm                  16384  1 btusb
btintel                32768  1 btusb
bluetooth             724992  91 btrtl,hidp,btintel,btbcm,bnep,btusb,rfcomm

Is it possible this is an issue with btusb?

Did you try the coexist?

Edit:

About iwldvm support and known issues

Wi-Fi / Bluetooth coexistence

Having Wi-Fi and Bluetooth running at the same time is a challenge. These scenarios have been tested thoroughly on 7260 and up, less so on earlier devices. This is why some people may face issues with devices that are handled by iwldvm. For users of these devices who have problems when Wi-Fi and Bluetooth are running concurrently, we suggest to disable BT Coex by loading iwlwifi with bt_coex_active=0 as a module parameter.

Which DE are you using?
I added a screenshot (using KDE), so you can see, how to make your system visible for the devices you want to connect to.

Did you try?

sudo modprobe btusb 
sudo systemctl restart bluetooth 

I do see currently a lot of users reporting issues with intel BT…

  1. try LTS Kernel to sort out a kernel issue.
  2. check rfkill status to see if it does not get blocked

I’m not using WiFi at all so coexistence should not be an issue. I have enabled the module parameter as well.
I am on gnome so I do not have the bluedevil gui although I have enabled discoverable through bluetoothctl by selecting the controller and typing discoverable on which is successful.
Restarting bluetooth after modprobe btusb doesn’t do anything either.
As for the LTS kernel, I have tried it before and it did not even recognize that I had a WiFi chip nor did it recognize an available Bluetooth controller which at least works for my current kernel.

I’m not a Gnome user. Have you tried gnome-bluetooth?