Intel AX210 issues on Asrock Deskmini X300

Wanted to add a WiFi+BT to my X300 Deskmini, so I went and bought the Intel M.2/WiFi+BT AX210. Was about around 25€ on eBay.

Well, some strange thing happened.

The module is recognised all right. But the Bluetooth performance is subpar, almost nil.

WiFi reception and range, same weak signal and detects only my close AP.

I have EndeavourOS with the latest updates, tried a few things to alleviate this issue, but it seems that AX210 has a compatibility with the AMD platform or something is amiss.

Tried switching between Zen and mainline kernel. No dice, same thing.

lspci detects the WiFi card properly, but only after I downloaded the latest Intel driver and copied it into /lib/firmware.

Booted the computer with a live USB with Fedora, PopOS, same thing.

Have I got a dud card? Is there something what I could try to solve this?

There are frequent updates to the firmware for the AX210 so it wouldn’t surprise me if that affected performance.

If you have 20220411.705f19a-1 maybe try downgrading to the previous version and see if that’s any better. If not, check for coexistence modes etc. in case there’s 2.4GHz interference.