Intel AC 3165 driver

Hi there :slight_smile:
i have installed the last iso and while in live the wifi was working once the installation is finished I can’t load the drivers

PC: Teclast F7 Plus
Wifi card: Intel AC 3165
Kernel: 5.19.7-zen2-1-zen(64bit)

Not sure what you mean by this. It should work on iwlwifi kernel module. Have you tried booting in the standard current kernel? I see this is zen-kernel.

Edit: What does this show?

sudo dmesg | grep iwl

Welcome to the forum @Franck :enos_flag: :partying_face:


Check the file

cat /etc/modprobe.d/iwlwifi.conf 

You may need to set powersave option.

options iwlwifi swcrypto=0 bt_coex_active=0 power_save=0

Edit: Add the above options and reboot. See if that works.

Where i have to add the above options?
I don’t have the first file

You would have to create it then.

sudo nano /etc/modprobe.d/iwlwifi.conf


options iwlwifi swcrypto=0 bt_coex_active=0

Ctrl + o then enter to save
Ctrl + x to exit nano

Still nothing
It seems likes there Is no driver

Please, dont post images from your screen. Instead, try posting your shell-command output by using ‘Preformatted text’ (Symbol is this: </>) in your post-editor, after highlighting/ marking the pasted content.

This way, it will be readable more easily, and searchable at the same time.

Doing it this way, can you post the output of this shell-cmd here?

inxi -Fzxxxa

…and welcome @Franck to this forum!

“Let us alll be frank with each other!” :wink:

1 Like

Ok ok thx

[franck@franck-linux ~]$ inxi -Fzxxxa
  Kernel: 5.19.7-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-linux-zen
    root=UUID=b171473d-646b-4344-9e0e-6ad2c0d13915 rw quiet
    intel_idle.max_cstate=2 loglevel=3 nowatchdog nvme_load=YES
  Desktop: KDE Plasma v: 5.25.4 tk: Qt v: 5.15.5 wm: kwin_x11 vt: 7
    dm: LightDM v: 1.32.0 Distro: EndeavourOS base: Arch Linux
  Type: Laptop System: TECLAST product: F7 Plus v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: TECLAST model: F7 Plus v: 3.1 serial: <superuser required>
    UEFI: American Megatrends v: tPAD 3.07 date: 12/26/2019
  ID-1: BAT0 charge: 28.2 Wh (78.8%) condition: 35.8/37.0 Wh (96.7%)
    volts: 7.6 min: N/A model: N/A type: Unknown serial: <filter>
    status: discharging
  Info: model: Intel Celeron N4100 bits: 64 type: MCP arch: Goldmont Plus
    built: 2017 process: Intel 14nm family: 6 model-id: 0x7A (122) stepping: 1
    microcode: 0x3C
  Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 224 KiB
    desc: d-4x24 KiB; i-4x32 KiB L2: 4 MiB desc: 1x4 MiB
  Speed (MHz): avg: 797 high: 800 min/max: 800/2400 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 796 2: 796 3: 800
    4: 796 bogomips: 8755
  Flags: ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
    filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel GeminiLake [UHD Graphics 600] driver: i915 v: kernel
    arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports: active: eDP-1
    empty: DP-1,HDMI-A-1,HDMI-A-2 bus-ID: 00:02.0 chip-ID: 8086:3185
    class-ID: 0300
  Device-2: Alcor Micro USB 2.0 Camera type: USB driver: uvcvideo
    bus-ID: 1-8:4 chip-ID: 058f:5608 class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.4 compositor: kwin_x11 driver: X:
    loaded: intel unloaded: modesetting alternate: fbdev,vesa gpu: i915
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 mapped: eDP1 model: ChiMei InnoLux 0x14c9 built: 2016
    res: 1920x1080 hz: 60 dpi: 157 gamma: 1.2 size: 310x170mm (12.2x6.69")
    diag: 354mm (13.9") ratio: 16:9 modes: 1920x1080
  OpenGL: renderer: Mesa Intel UHD Graphics 600 (GLK 2) v: 4.6 Mesa 22.1.7
    direct render: Yes
  Device-1: Intel Celeron/Pentium Silver Processor High Definition Audio
    vendor: Realtek driver: snd_hda_intel v: kernel
    alternate: snd_soc_skl,snd_soc_avs,snd_sof_pci_intel_apl bus-ID: 00:0e.0
    chip-ID: 8086:3198 class-ID: 0403
  Sound Server-1: ALSA v: k5.19.7-zen2-1-zen running: yes
  Sound Server-2: PulseAudio v: 16.1 running: no
  Sound Server-3: PipeWire v: 0.3.57 running: yes
  Device-1: Intel Wireless 3165 driver: N/A modules: iwlwifi pcie:
    speed: Unknown lanes: 63 link-max: gen: 6 speed: 64 GT/s bus-ID: 01:00.0
    chip-ID: 8086:3165 class-ID: 0280
  IF-ID-1: enp0s21f0u2 state: up speed: 425 Mbps duplex: half mac: <filter>
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
    bus-ID: 1-7:3 chip-ID: 8087:0a2a class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: disabled
    rfk-block: hardware: no software: no address: see --recommends
  Local Storage: total: 238.47 GiB used: 13.22 GiB (5.5%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Teclast model: 256GB NA850-2280
    size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 6A0 scheme: GPT
  ID-1: / raw-size: 238.17 GiB size: 233.38 GiB (97.99%) used: 13.22 GiB
    (5.7%) fs: ext4 dev: /dev/sda2 maj-min: 8:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 312 KiB
    (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  Alert: No swap data was found.
  System Temperatures: cpu: 47.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 215 Uptime: 31m wakeups: 4 Memory: 7.58 GiB used: 1.72 GiB
  (22.7%) Init: systemd v: 251 default: graphical tool: systemctl
  Compilers: gcc: 12.2.0 Packages: pacman: 1105 lib: 279 Shell: Bash
  v: 5.1.16 running-in: xfce4-terminal inxi: 3.3.20
[franck@franck-linux ~]$

This is the result

It shows iwlwifi should be your driver, as @ricklinux found, but apparently it isn’t installed!

Next step would be this one:
sudo pacman -S linux-firmware
…and reboot.

Does your WiFi work after these 2 steps?

The device is supported by kernel versions from 4.2 to 5.12 according to the LKDDb


So i have to use a older kernel?

Might be worth trying.

Have a look here:

1 Like

LKDDB is also not updated :stuck_out_tongue:

I was thinking the same.

Did you try this?

as for now try it to use linux kernel, you said in tg it worked in live environment. but you using linux-zen… would figure bit out in linux kernel.

by checking :stuck_out_tongue:

i saw this →

About dual-boot with Windows and “fast-boot” enabled

If you have a dual-boot machine with a recent version of Windows and start seeing problems during initialization of the WiFi device when booting Linux, the problem could be due to the “fast startup” feature on Windows.

With this feature enabled, Windows don’t really shut down the entire system, but leaves things partially running so you can start the machine faster again. Try to disable this option, on Windows 10 it should be in “Control Panel→Hardware and Sound→Power Options→System Settings”. Select “Chooose what the power buttons do” to access the System Settings from the Power Options. Then disable the “Fast Startup” option in “Shutdown Settings”. This will cause Windows to fully shutdown and may solve the issue.

might be interesting ?

If you are dual booting then yes as @ringo pointed out you should disable the fast startup feature in Windows because it uses hiberfile and prevent the hardware from starting in Linux.