Installing on an external hard disk fails

All in a sudden, while I was using my computer for more than one hour, Plasma started complaining because some configuration files weren’t writable. I could not even open Konsole.

I decided to install EOS on an external USB hard disk (1 TB), but all the times I try, the installer closes after I selected on which hard disk to install, the filesystem to use, and whether to use a swap partition. I can only see the selected hard disk that from formatted as BTFRFS is shown as formatted (with the partitions the installer is going to add); then, I see the Scanning storage devices… message and all the installer windows close.

I also re-flashed the USB live disk I use to install EOS, using the ISO I dowload from, but that didn’t help.

How can I install EOS on an external disk?

(I apologize for the updates to the post: I am posting from another computer while I try to install EOS.)

As additional information, at the third time I re-open the installer to try again, it doesn’t open anymore. I have to restart the computer before I can run the installer again.

I assume you decided to install to an external drive because your hard drive is no longer working after the crash?
You can run the installer from the terminal in the live environment of the Endeavour OS installation medium:
sudo /usr/bin/calamares -style kvantum -D8
This will give you feedback in the terminal that can be used to determine what is happening when the installer crashes.
I suggest you check the ISO file of EOS to make sure you have an ISO file that is not corrupted. You can also run gparted in the live environment to first format and partition the USB drive yourself, before running the installer with the command above. I would also suggest that more could going on with your system than just the disk. Make sure you are not having problems with other devices in your system, including RAM and CPU. You can do this by trying to load and run other live systems from other distros to see if you have the same issue. Also, try to eliminate the possibility that the external hard drive is bad. If you can format/partition it in gparted first, apply the changes and all seems to go well, it is a good indication the drive is ok.
Run the installer from the command line as directed above and post any relevant output.

1 Like

The last lines output on the console before the installer closes are the following.

[6]: getting smart status failed for  "dev/sdc" :  Success
[6]: error during smart status parsing for  "dev/sdc" :  Success
[6]: QML component (default slideshow) Next slide
Segmentation fault

Try running Gparted from the installer and partitioning the disk yourself. I am not convinced that your installation medium is good/verified.

I will first buy a new USB flash drive to be sure that isn’t the problem. I noticed that, in some cases, using it to install for the second time causes problems, if I don’t first flash again the install ISO (which I did also this time).

I flashed the ISO file on a new USB key I bought right before using it, tried to install from that USB key, but the installer still stops at the same point. I even formatted the USB hard disk as EXT4, but that didn’t help.

I start thinking that, despite the fact the partition module is slow to be loaded (I even wait 2 minutes before I can click on Next after selecting the language), and that the installer is slow to show how the hard disk will be partitioned (and to scan for devices), the computer doesn’t have just hard disk problems.

After a failed install, in the live session, could you launch eos-log-tool and check as many boxes as possible in the gui and post the resulted URL on the forum? The info might give someone some idea what the issue might be.

1 Like

I understand that you believe the source disk with the EOS installation iso is good. Are you sure the destination disk is not faulty? Have you tried manually partitioning the destination disk with gparted in the live environment? If this also fails, it is likely the destination drive is bad.
If the source usb drive is fine and the iso file was verified using the Sha512sum, and you are still getting segmentation faults, then another troubleshooting step is run a memory check on the RAM. Bad RAM can cause segmentation faults in applications. A faulty CPU can cause the same issues.
As a last resort, you can also try a different distro to see if you get the same issues. Good luck.

I formatted the external hard disk using GParted; at the successive tentative to install EOS, the hard disk was shown to be formatted as I did. I verified the ISO file was intact, and it was.

Essentially, I wanted a confirmation that, to install EOS on an external hard disk, I just had to select the external disk as the one to use for the installation. The fact the internal hard disk give read errors should not stop the installation, and there isn’t any option to “ignore” the errors from the internal disk.

I tried, but for some reason, the URL given for the log contained just the domain name. The resulting log was a little bigger, probably because the journal (which I remember was filled up with AER errors since the first time I installed EOS on that computer).

I will try again tomorrow, leaving out the journal and hoping there is still information that helps to understand whether the computer has bigger problems.

1 Like

It seems to me, it is an issue with KDE, checking for your HD smart status (KDE does this per default). I’ve had such issues in the past…

Disabling “smart status check” in KDE might do the trick, if you ask me. But for that, you’d need a running KDE installation… (if noone else could explain how to do that beforehand an installation of EnOS).

Also, your HDD might actually be getting old… what I did when it occured to me was reformatting the drive to blank, and re-installing. After that, the problem was gone for good (over 2 years to this day). Mind - several OS-changes had been involved, including Windoze Vista on that very old hard-drive!

  • Don’t forget to cold-boot after deleting all existing partitions, before creating new ones!

No OS ever started complaining after that, not even on KDE.

First, after a new installation (and complete re-formatting), I disabled the smart-check in KDE settings, and later I never bothered with it again, later turning my back to KDE, as it is not my daily driver anymore, except for one machine (but that has an internal SSD)…

No issues to this day!