Installing EndeavourOS Cassini on a PineBook Pro

Yes, once :enos: controls the bootloader everything will be fine.

We use tow-boot and I test it a lot if I update it. But I haven’t updated it in a while and I know that it works.

You will be able to boot other distros using the tow-boot using SD or USB.

I got the adapter and did the burning procedure.
Put back the eMMC and tow-boot shows up and boots EndeavourOS (for the installation).
Unfortunately, then the screen stays blank… maybe it’s just that the graphic card broke…

wait… as you said, tow-boot allows me to choose where to boot from.
I can now boot the old Arch installation I had on a USB stick, and it boots fine.
So I guess I have some problems with installation method number 3?
With method 3 I should get OpenBox for finalizing the installation, shouldn’t I?

1 Like

Correct. You should get an OpenBox session that launches Calamares.


But I don’t… the screen stays black… any clue about what I could try? By the way, the screen is black, but I can press Ctrl alt delete to reboot, so the system started.

@sradjoker some updates:

  • I confirm that when booting from the eMMC where I had installed EndeavourOS the screen stays black: I don’t even see the logging of booting in the terminal
  • I tried using method one: I booted with the ISO (on a standard PC) and used the Arm installer with a USB stick as the target
  • when I boot the PineBook Pro with the USB stick (I can select it from tow-boot) I see the logging of booting in the console and then OpenBox starts.
  • I have to relaunch OpenBox because the Calamares crashes
  • I finally managed to finalize the installation on the USB stick that works fine

I seem to understand that method one uses basically the same installation script of method 3? In any case, I never see OpenBox when I boot from the eMMC.

Is there anything I can do to debug the problem on eMMC? Can I enable some special boot options?

Thanks again

The same black screen problem was happening to me but I was trying to install endeavour from an SD card. I hope this will help you too.

The first time I booted from the sdcard the desktop loaded but I wasn’t connected to the internet when I tried to run the installer, after connecting to my wifi the installer wouldn’t load anymore so I decided to restart. After rebooting the desktop didn’t load anymore and all I could do was opening the right click context menu or ctrl +alt + f2.

To fix the black screen I had to reburn the image to the sdcard. After that I was able to open the installer again but connecting to the wifi stops the installer from working properly. I noticed that by disconnecting from the wifi allowed me to re-open the installer but it doesn’t let you move forward withouut an internet connection, so I had to disconnect from the wifi open the installar and quickly connect to the wifi… by doing this I was able to install endeavour on the sdcard. Another issue that happened during the installation is that for some reason using the letter ‘e’ was making something crash and a pop message was displayed so I couldn’t write the username that I wanted. Sorry I can’t give more details on this last issue but I can’t remember what the error said.

I would love the install it on the emmc but it seems like there are some issues with the live image that need to be iron out first.

Anyway I’m writing this from my pbp using endevouros from sdcard and everything is working great, thanks for all the work!

As I said in my previous answer, the key is to restart Openbox.

If you simply reboot, the installation media seems to have already been compromised.

some more findings:

  • both with method 1 and 3 (haven’t tested method 2), there’s no way to boot a device where you selected BTRFS: it boots, but then the screen stays black and OpenBox does not start; actually, there’s no even Console output. I’d say that the BTRFS installation is buggy
  • it’s OK with EXT4, but the installer silently crashes (when OpenBox starts) if you start the installation (after connecting to the Internet). As I said above, the solution is to Exit OpenBox, which will restart automatically and then the installer works
  • for method 3, you suggest to cd into /tmp: bad choice :wink: if you do the procedure from a machine with a few RAM (e.g., the PineBook itself), since the /tmp is mounted on memory, you’ll exaust the RAM, i.e., the space used for method 3, during the procedure leaving the target device completely unbootable.


have you install tow-boot to spi ? or you leave blank . No reason i just interested :wink:

I just used the installation process of EOS. When I did that on my eMMC, it automatically installed tow-boot

1 Like

that no what i ask . have you installed tow-boot to spi . that all i ask :wink:

EDit. on eMMC you have Arch ,manjaro or EOS ?

I have eos on emmc. As I said, as part of the installation it put tow boot. I don’t know about spi.

thank you for answer.

i just wonder as read you blog on
" Installing Arch Linux on a PineBook Pro (external storage) "

interesting :wink:

i also use external storage for boot some time .

[shjimblk@Arch boot]$ lsblk
sda            8:0    1   239G  0 disk 
├─sda1         8:1    1   256M  0 part /boot
└─sda2         8:2    1 238.8G  0 part /
mmcblk2      179:0    0 115.2G  0 disk 
├─mmcblk2p1  179:1    0   200M  0 part 
└─mmcblk2p2  179:2    0   115G  0 part 
mmcblk2boot0 179:32   0     4M  1 disk 
mmcblk2boot1 179:64   0     4M  1 disk 
mmcblk1      179:96   0 119.1G  0 disk 
├─mmcblk1p1  179:97   0    12M  0 part 
├─mmcblk1p2  179:98   0   256M  0 part 
└─mmcblk1p3  179:99   0 118.8G  0 part 
nvme0n1      259:0    0 476.9G  0 disk 
└─nvme0n1p1  259:1    0 476.9G  0 part 

How do you reset openbox? I’m new to linux.

Do you just delete ~/.config/openbox/ ?

Thanks :hugs:

A blog post about installing endeavouros on pinebook pro will follow shortly.

Concerning open box I mean: right click on the desktop, openbox, exit. Then it will go back to the console and automatically restart openbox.

think it more than

" The post is based on the instructions found at " :wink:

you missed
" If you already have Tow-Boot installed via SPI, you can skip this step. Use fdisk to create a blank GPT partition table. /boot will be partition 1, and / partition 2. "

As a follow-up: I finally published my experience of installing EndeavourOS on a PineBook Pro here:

By the way, BTRFS still does not work (I experienced the same problems I described in my first messages).


Thank you for the review. It is much appreciated.