Installing crossover - missing dependencies problem (32 bit)

I am trying to install CodeWeavers CrossOver
AUR seems to have a repository for Crossover
so git clone
sudo makepkg -si returned the bellow ERRORS
I suspect it is to do with 32 and 64 bits (I had similar problem with PureOS but not on Debian Bullseye)
Is this solvable on EOS?

 ==> ERROR: 'pacman' failed to install missing dependencies.
==> Missing dependencies:
  -> lib32-glibc>=2.11
  -> lib32-libice
  -> lib32-libsm
  -> lib32-libx11
  -> lib32-libxext
  -> lib32-libxi
  -> lib32-freetype2
  -> lib32-libpng
  -> lib32-zlib
  -> lib32-lcms2
  -> lib32-libgl
  -> lib32-libxcursor
  -> lib32-libxrandr
  -> lib32-glu
==> Checking buildtime dependencies...
==> ERROR: Could not resolve all dependencies.

Have you enabled the [multilib] repo in your /etc/pacman.conf?

1 Like

Ahh, no.
I suppose this is the section you’re talking about

# If you want to run 32 bit applications on your x86_64 system,
# enable the multilib repositories as required here.

#Include = /etc/pacman.d/mirrorlist

Include = /etc/pacman.d/mirrorlist

SigLevel = PackageRequired
Include = /etc/pacman.d/endeavouros-mirrorlist

should I uncomment the [multilib-testing] ???

No, if you haven’t enabled other testing repos in that file.
You can try installing the dependencies with pacman in advance as well.

Usually it is best to show the full output of a failing command. If the output is long, you can use e.g. eos-sendlog command, piping it to pastebin and show the returned URL here.

core/lib32-glibc 2.33-5 (3.5 MiB 18.4 MiB) (Installed)
    GNU C Library (32-bit)

multilib/lib32-freetype2 2.11.0-3 (348.0 KiB 797.6 KiB) 
    Font rasterization library (32-bit)

multilib/lib32-glu 9.0.2-1 (138.0 KiB 345.5 KiB) 
    Mesa OpenGL utility library (32 bits)

checking only 3 but they all should be in the repos…

just start build and install using yay without issue …

yay -S crossover

Ok thank you @manuel - I’ve updated system and it seems that the advice from @joekamprad yay -S crossover works.
Thank you both