Installing a LAMP Stack with PhpMyAdmin in EndeavourOS

good day dear community, hello dear friends, :grinning:

i am fairly new to EOS - and i just want to install a LAMP-Stack on a freshliy installed notebook
well - could you tell me which manual is the best one here - i found a couple of interesting looking ones - see below

a. How to Install LAMP Stack with PhpMyAdmin in Arch Linux (pulished 2017)

b. LAMP Installation pulished 2021
https://wiki.archlinux.de/title/LAMP_Installation

c. How To Install Linux, Apache, MySQL, PHP (LAMP) stack on Arch Linux (Published on September 7, 2012)

Which one is appropiate - and which one would you use.

generally - i think it is a good starting point doing like so: as allways - before installing any of the LAMP programs, we should take care for a frehs and updated machine:

Then i think its time to update the package manager:

sudo pacman -Syu

well - this is the vey first step: after the process of update is complete, we can install Apache:

sudo pacman -S apache

After Apache is installed, we have to make a couple of changes in the configuration of the machine:

Therefore we open up the apache configuration file:

sudo nano /etc/httpd/conf/httpd.conf

Here we need to comment out the unique_id_module (we can use ctrl w to find it quickly):

#LoadModule unique_id_module modules/mod_unique_id.so

now its time to restart the installed Apache:

sudo systemctl restart httpd

Well - after doing so - that means after the apache restart, we may get a notice that says the following:

httpd: apr_sockaddr_info_get() failed for droplet1 httpd: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName [DONE]

and so on and so forth: … which manual would you suggest to use!?

Love to hear from you

regards
Otrott :wink:

They all look about the same to me except to the one in German which I can’t read :wink:

Most of them are pretty reasonable.

2 Likes

Have you considered a more modern version, the LEMP stack.

Pudge

4 Likes

Option (a) looks pretty comprehensive:

2 Likes

good day dear Morse, dear Pudge and Dalto,

many many thansk for the quick reply - i am glad to hear from you. I will start with the installation.

hi there dear @morse , @dalto -good evening dear Pudge,

  • good day, guess that i run into some issues,

$ sudo systemctl start httpd 
$ sudo systemctl enable httpd
$ sudo systemctl status httpd


   Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled; vendor preset: disabled)
     Active: active (running) since Sat 2022-03-26 22:16:52 CET; 1min 14s ago
   Main PID: 3473 (httpd)
      Tasks: 82 (limit: 4566)
     Memory: 6.7M
        CPU: 155ms
     CGroup: /system.slice/httpd.service
             ├─3473 /usr/bin/httpd -k start -DFOREGROUND
             ├─3474 /usr/bin/httpd -k start -DFOREGROUND
             ├─3475 /usr/bin/httpd -k start -DFOREGROUND
             └─3476 /usr/bin/httpd -k start -DFOREGROUND

Mär 26 22:16:52 martineos systemd[1]: Started Apache Web Server.
Mär 26 22:16:52 martineos httpd[3473]: AH00558: httpd: Could not reliably determine the server's fully qualified domain name, using fe80::bd0b:cc95:9fd2:82e2%enp4s0. >

~

hmm - do not know what that means exactly here - and if i should / could continue

apachectl configtest
check the output

usually this error is because the FQDN is not properlyu defined. open that file with nano, vim, etc…

/etc/apache2/apache2.conf

here is where you need to define the proper FQDN. for testing only, set it

ServerName 127.0.0.1

save it, run apachectl configtest and see if outputs OK
if so, open a browser and point to the IP of the server, not the domain name
BTW, do you install that stack on a VM, cloud instance or local machine?
Do you have a domain name?

1 Like

Hello and good evening dear @Anticupidon

many thanks for the reply.

regarding the editing of the apache2.conf - well i guess

The simplest way is to open the file with the sudoedit program, as in
sudoedit /etc/apache2/apache2.conf
which will prompt for your password and then open your editor.

so i guess - that i should use this:

sudoedit /etc/apache2/apache2.conf

[root@martineos martin]# apachectl configtest
AH00558: httpd: Could not reliably determine the server's fully qualified domain name, using fe80::bd0b:cc95:9fd2:82e2%enp4s0. Set the 'ServerName' directive globally to suppress this message
Syntax OK
[root@martineos martin]# sudoedit /etc/apache2/apache2.conf
sudoedit: /etc/apache2/apache2.conf: Datei oder Verzeichnis nicht gefunden
[root@martineos martin]# sudoedit /etc/apache2/apache2.conf
sudoedit: /etc/apache2/apache2.conf: Datei oder Verzeichnis nicht gefunden
[root@martineos martin]#

well regarding your other question - install this on a local machine - no i do not have a domain-name.

i just want to have a test-environment for setting up a wordpress-installation locally

look forward to hear from you

I’m not familiar with sudoedit but it seems to do the same as sudo nano. Anyway, the file you need to edit is /etc/httpd/conf/httpd.conf because apache service is installed as httpd and not as apache2; this last service name is used in Ubuntu and derivatives. This is described in the 6th step of the guide you’re following, bellow the image linked.

By the way, from your terminal prompt [root@martineos martin]#, you are running everything as super user. I’m in favor to be logged in with my current user and preppend sudo only for commands that need elevated privileges.

Are you by any chance installing an Arch instance to use as a server on DigitalOcean? If so I’d rather recommend sticking with one of their Ubuntu images and follow one of the guides they provide for Ubuntu. For headless standalone server it’s a much more stable setup. An install it and forget it kind of deal.
If it’s a dev machine then that’s a different thing.

1 Like

Installing Wordpress on a local machine can be easily done by using Xammp.
Have a peek

https://bitnami.com/stack/xampp

Xammp was designed to simplify develpment, to have a Wordpress or another CMS or service up and running fast.

As @nate said, it’s easier and simpler to use tried and stable ISO with production ready server solution. Don’t try to reinvent the wheel, use a tested and well oiled wheel, and focus on Wordpress and its content.

It is ok to tinker and try new things, but that comes with some time and frustration involved.

I use now LAMP Turnkey LXC on my Proxmox as a template. I use Linode, Vultr, Digital Ocean.
But somehow I come back to my Proxmox machine where I can run a LAMP stack or Docker in a LXC container with 80% less resources.

Sorry for the slight thread derail.
Give us some feedback, we are here to help.
Cheers!

otrott,

I agree with nate that using an Ubuntu/Mint OS in this instance is more straightforward, but don’t let me put you off EndeavourOS.

It is a bit like the old joke about the lost tourist asking for directions from a farmer and getting the reply, “Well I wouldn’t start from here”.

Here is a comprehensive guide to Installing WordPress on a LAMP server using Linux Mint/Ubuntu/Debian:

I used this myself as a test-run for a proposed website before it went live via a web host.
Everything worked perfectly.
Good luck.

1 Like