Installer tries to install AUR package with pacman

The installer tries to install xcursor-neutral with pacman, however it’s an AUR package (and a pretty new one, first submitted 1st of april).

1 Like

Welcome to the forum!

It looks like one of the packages used in several of the community editions is no longer in the repos and has been dropped to AUR.

That is why it appears as a new AUR package.

Thanks for reporting it!

Thanks for answering so quickly, do you know of a fix until a new iso is released? I tried linking yay to pacman, so that it would install it, but that didn’t work.

Before launching the installer, edit /etc/calamares/modules/packagechooser_ce.conf and remove the lines with that package in it.


Thank you very much for the quick solution, it worked perfectly!


thanks for report just started to inform Community Edition Maintainers to check the configs.
Working on a hotfix for it now.

1 Like

Hotfix was just implemented for the latest R1 ISO.
If there is any problem with it, please report.



Hi! How do I install the Hotfix? I re-downloaded the latest iso and the same error was triggered again.

It should be automatic. Make sure your network is up and running before you launch the installer.

It is! I downloaded the latest iso from the Germany mirror.
EDIT: Also, toggled the log during installation and all packages are properly downloaded.

What is the filename on the ISO you downloaded?



could be gitlab is blocked from where you stay ?

If it isn’t working, you can always just make the simple manual edit recommended above.

That is the same thing the hotfix is doing.

1 Like

you can untag the xcursor-neutral package also on that screen.

if you do not mind please check the installer log for us so we can see why the hotfix is not getting applied for you:

cat ~/endeavour-install.log | eos-sendlog

from the livession and post the url here…

Checking it right now, will get back ASAP.

Yep, that did it! I edited /etc/calamares/modules/packagechooser_ce.conf and the installer worked.


1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.