Installer ISO Beta testing

Write here what you think about our Beta release and give us all you find out, what you like and what not.

If you like to contribute to development itself join us at GitHub:
EndeavourOS - Development @github
…also the place to place bugreports directly.

1 Like

2 Likes

Not sure if this is the right spot but I’m having two problems with the beta.

  1. When I installed it, I selected the auto-login option but I get prompted for a password every time I boot up.

  2. I tried installing Cinnamon: sudo pacman -S cinnamon nemo-fileroller

… but when it goes to install, I get non-stop errors as packages are trying to be retreived:

1 Like

That option comes by default in calamares installer. Untill we make it work may be better remove it.

About error while installing the package: Do you have internet connection? I installed many packages here and got some errors due bad mirrors, but i could download the packages from other mirrors.

you can

sudo pacman-key --init
sudo pacman-key --populate
sudo pacman-key --refresh-keys
sudo cp /etc/pacman.d/mirrorlist /etc/pacman.d/mirrorlist.bak
sudo reflector --verbose --age 8 --fastest 128 --latest 64 --number 32 --sort rate --save /etc/pacman.d/mirrorlist
sudo pacman -Syu
or even 
sudo pacman -Syyu
1 Like

Yup, I have internet and unfortunately, after carrying out your commands… no change.

https://bin.privacytools.io/?650aca302ade342d#PUxy+Jrs5BRL10XkbUkVqR6hYRY/BL1yOoBam6z0fj8=

error: failed to commit transaction (unexpected error)

Errors occurred, no packages were upgraded.

[roadhazard@virtualendeavour ~]$

i can see it tries downloading old versions:

pacman -Ss xapps                          
community/xapps 1.4.7-1
    Common library for X-Apps project

Your database is not updated…

sudo pacman -Syu

and please @roadhazard do not paste endless logs here and instead use a pastebin service to make post better readable…

if my recollection is correct, adding autologin is possible in System Settings, listed under either SDDM or Startup and Shutdown/Advanced tab

ooops, I should have specified the previously mentioned tip is at least in KDE Plasma… however, I believe it also relies on using SDDM.

Decided to try Endeavour’s Beta 2.1.
In the Live environment was a short time and immediately installed it on virtual disk.
Some significant difficulties in the installation process did not arise. But I don’t like XFCE :blush:
I started to configure the system for myself, and, as usual, it turned out all the same KDE Plasma :rofl::rofl::rofl:
LightDM replaced with SDDM.
In general, we can say that even now, even at the Beta stage, EndeavourOS is quite a viable system! :+1:

3 Likes

Hi Joe, first, sorry about posting all the text! I won’t let it happen again.

As for my problems with installing Cinnamon, my super noobiness strikes again! -Syu fixed it! Sort of. Cinnamon installed but when I was at the login screen, I didn’t see the option to select Cinnamon as my desktop manager. I think I’m just going to wait for the final product.

Come on July 15th!

1 Like

1 Like

I just installed Cinnamon and didn’t have any issue but i only used sudo pacman -S cinnamon. I don’t really like installing two desktops this way. I’m waiting for the online installer so i can choose. But right now i have no choice.

roadhazard it doesn’t work as of yet but you can set it up manually. I found this information a while back and is how to make it work in Arch Linux:

How to Enable autologin in LighDM

  1. Open a terminal and type:

sudo nano /etc/lightdm/lightdm.conf (can be leafpad, mousepad, geany, ect.)

  1. Scroll down the page and find the lines:

#autologin-guest=false
#autologin-user=user
#autologin-user-timeout=0

  1. Uncomment the lines by removing the “#” in front of each line. Change the autologin-user field to your username. It will look something like this:

autologin-guest=false
autologin-user=damien
autologin-user-timeout=0

  1. Save the file by pressing Ctrl + O and exit (using shortcut keys Ctrl + x).

In Arch Linux, you have to add your user to the autologin group before it can work:

sudo groupadd -r autologin
sudo gpasswd -a username autologin

Restart your computer and it should autologin.

3 Likes

we will have a look into this, may we need some extra configuration here.

This is more a personal taste. I have manny DEs, like 8 installed, and don’t have conflicts or issues here.

I am sooo tempted to install the Beta, but the full release previews look great out of the box, with the new logo and everything…

Wow, I thought it would end up with some conflict somewhere along the way. So if that’s the case I’ll give it a chance and see if maybe i will start to like it. I guess the advantage is you don’t have to restart, just log out and go to another desktop.

1 Like

You can test it, hope ot works for you.

Thanks a lot! I didn’t know about the login groups in Arch and couldn’t get the autologin to work without a 60 second pause in the bootup. This fixed it!

I wanted to ask what dock you are using and also how you installed plasma and sddm?