Installer fails - waiting for partitioner - locks up PC

I’ve tried to install Cassini on an HP laptop and a home built PC. On both computers, every time I try the installer it waits indefinitely for the partitioner. I can’t cancel the installation and have to do a hard reset.

The computers are just standard UEFI, nothing special, and every distro I’ve tried installs without problems.

// moved to General System Installation //

Welcome here on the forum :enos:
We are sorry to hear that you are having problems with the installation!
To get any hint on what goes wrong for you we would need partition/drives information and hardware overview.

You can get these before starting the installer if the system locks up on you, which is very uncommon, I do never had someone reporting this.

hardware info:
inxi -Fxxc0z | eos-sendlog

some error logs from boot could hint to us too:

sudo dmesg -rl warn,err,crit | eos-sendlog

partitions and drive info:
sudo fdisk -l | eos-sendlog

And some detailed information about how you created the install media will be good… because some methods are proven to cause issues.

Also you are may a bit frustrated, it would help us a lot to find the issue!

Both computers are dual boot with Windows 10, separate NVME drives for the OS’s. Another distro using the Calamares installer has the same fault, so Calamares is the culprit. GParted, run from the live session, shows all paritions perfectly.

I’ll collect the diagnostic info. in an hour or so.

I used Rufus in ‘dd’ mode, I didn’t think that would be an issue but, I’ll create the bootable media using ‘dd’ in Debian 11.


1 Like

what Distro? so I can check what versions in use ?

both should be fine… also rufus can cause issues but it should detect hybrid ISO and ask to burn in ISO mode or dd mode.

I would be very happy to take a look!

from experience rufus is not the best choice…
to use GDU or dd promises more success :wink:

The other distro was “Arch Linux GUI”, KDE Pure iso.

I created a new ISO using Debian. Still the same problem - the installer will freeze the desktop after waiting 129 seconds for the partitioner.

I’ve sent the requested information.


Where did you send it?

and not developed anymore (abandoned)

I ran the commands described above. Piping the output to eos-sendlog sent the data to Endeavour tech support.

We actually need the output of those commands, which are URLs.
There is no such thing as “Endeavour tech support”. :person_shrugging: It’s just us, the forum.

1 Like

hmm we are the tech support as the users here at the forum do help each other… in addition, devs are here too… you send them via info[at] you can send me in a P.M. here if you concern about private on the logs but the 3 commands I have you will not have much personal information.

seems the info is a bit misleading on our website…

Okay if there is an issue downloading ISO from the servers… but installation issues should only be posted at the help forum or chats… and if someone knows what exactly is the issue GitHub issues could be a place too in cases…

eos-sendlog, doesn’t send your logs to us. It sends them to a pastebin-type service and gives you a link you can share with us here in the forum.

1 Like

I’ve just tested another Arch based distro that uses the Calamares installer (the one begining with ‘M’). That installer worked. It’s probably Calamares itself that’s causing issues.

If you would still like diagnosic information I’ll send it again at the weekend.

Thank you for your fast replies and support.

It is entirely up to you. Without seeing the logs, there is no way for us to know why it is failing.

1 Like

I’ve resolved this. There where LUKS partitions from a previous installation.
My solution was to boot into the live desktop, run the partitioner and format or erase the LUKS partitions, then run the Calamares installer. That worked as expected and I now have a dual boot Endeavour/Windows 10 installation.

I tested a few distros with the Calamares installer, all but one failed.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.