Installer fails to fetch packages online mode

So I couldn’t figure out why the package selection would show disabled and I wasn’t able to select a custom DE like KDE in the Calamares installer.

I had to change the url in the netinstall.conf file!
This is what I changed it to for it to work…



Edit: how to edit the file

1 Like

Welcome Aboard! Which release did you use?

Thanks Elloquin I used endeavouros-2020.09.20-x86_64.iso

Help from Joe Kamprad on telegram really helped me figure this out!


Glad it’s working for you now. Welcome to the community :beers:

1 Like

we are discussing this on development and working on solving this for next release already, we find that their must be a change to the way GitHub is handling urls.
We have this also on other places and currently working on changing urls inside the framework.

1 Like

I’ll be waiting for a new iso before daring to install EOS again. Even when I try the offline mode, there is a moment when I am informed that the network Ethernet is running 100 Mb/s with r8169 and when the EOS installer tells me there is no Internet connection (because in offline mode you still need an Internet connection to select some packages). Of course you can follow on, but my experience is that it leads to a defective install and further problems along the way that should not appear.

Now I am writing from Windows 10. My EOS stuck in Xfce froze and died, painlessly I hope. See you at the next iso.

In my country there is not youtube access. You need to click on the image to get it greater.

Offline install do not provide extra package selection, this is only available if you choose online on installation starting. You can disable network from panel right side also to make sure to not use it.

It will not show the package selector:

If package selection is available you choose online method:

r8169 ? a troublesome chip.

1 Like