Installer "black's out" before live environment

Hello, for context I am trying to download Endeavour OS on the 12th gen Intel Framework Laptop. The laptop has the i5-1240P with integrated Iris Xe Graphics.

On my installation medium, I am unable to get past triggering uevents upon running the default installer in the grub menu. I have used three different USBs, and I have tried the worldwide and USA mirrors for the ISO. The programs I used were Rufus and balenaEtcher. All resulted in the same thing.

Upon adding nomodeset to the grub kernel parameters or using the nomodeset profile in the menu, I am able to go past the triggering uevents line. However, as soon as I make it to the welcome screen, the installer goes kaput. The installer starts flickering its text it’s text rapidly to eventually show only a black and blank screen. Afterward, I am only left with pressing the power button to exit. However, my shutdown is also having issues as it hangs at the very last line. There, it also says Software reset failed: -524 and reboot: Power down. The laptop does not shut down and I am left with holding the power button.

I noticed this similarly happens in the regular arch installation media too, just minus the flickering and only staying stuck at the same text.

Is it possible to obtain logs when I can’t make it past the loading screen?

Edit: I noticed in the video I took of the “flickering” that it ends with

Xinit: giving up
Xinit: unable to connect to X server: Connection refused
Xinit: server error

Not sure if this is significant

procedure I::

  1. check bios boot mode (set to uefi mode, not csm [legacy bios boot] )
  2. unplug Xe card
  3. reboot the live ISO

procedure II::
5) no Xe card
6) install another arch iso and use an arch usb burner to brun endeavour ISO or use mintstick (the best suggestion)
7) reboot the live ISO

procedure III::
8) no Xe card
9) download endeavour iso < 6.0 with xf86-video-intel and grub default (though the old version may not have somethings in repo to use)
10) boot the live ISO, then upgrade to 6.2.11

If endeavour system is booted, plugin Xe card to do new configuration.

if still not works after all above tries, just wait for some expert users’ help.

see this

you need to find “pci card” and add this on boot kernel ( kernel >= 6.0 )
requires setting the i915.force_probe=[PCI-ID] module option to force the driver to initialize the graphics card.

sudo dmesg | grep i915

I don’t like to say anything about intel cpu here again, but today i learn a good configuration info from Stephane, so i would like to repeat the thing here.
After successfully booting the endeavour os, the followings may be considered.

A good configuration for game in intel cpu environment:: ( ### if you don’t have grub installed, just don’t do the followings )

$ sudo pacman -Syu (must)

$ sudo pacman -S xf86-video-intel

$ sudo pacman -S intel-media-driver

$ sudo pacman -S intel-ucode ( produce /boot/intel-ucode.img )

$ sudo pacman -S linux-firmware (if needed)

create /etc/modprobe.d/i915.conf ::

options i915 enable_guc=3
options i915 enable_fbc=1
i915 force_probe=[PCI-ID] # from Stephane, use as parameter in grub.cfg i915.force_probe=[PCI-ID]
#options snd-hda-intel enable_msi=1 # for no crackling of pipewire

create /etc/X11/xorg.conf.d/20-intel.conf ::

Section “Device”
Identifier “Intel Graphics”
Driver “modesetting”
Option “DRI” “iris” # DRI3 is now default

(sudo) edit /etc/mkinitcpio.conf ::

MODULES=" intel_agp i915 "

(sudo) edit /boot/grub/grub.cfg ::

echo ‘Loading initial ramdisk’

linux /boot/vmlinuz-linux root=UUID=xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx rw quiet xxxxxxxxxx xxxxxxx ibt=off (add ibt=off for virtualbox)
initrd /boot/intel-ucode.img /boot/initramfs-linux.img (add /boot/intel-ucode.img)

$ sudo pacman -S mesa libva libmfx intel-ucode intel-media-driver intel-gmmlib lib32-mesa ( ---------- check first, if not exists, install it)

------------ optinal
$ sudo pacman -S libva-intel-driver libva-mesa-driver libva-vdpau-driver libva-utils lib32-libva lib32-libva-intel-driver lib32-libva-mesa-driver lib32-libva-vdpau-driver iucode-tool vulkan-intel lib32-vulkan-intel intel-graphics-compiler intel-media-sdk intel-opencl-clang
------------ optinal

$ sudo mkinitcpio -p linux
$ reboot

I wanted to reply as I had the exact same issue (on an old laptop with minimal specs). My fix to get the installer running was to force the laptop to use “Legacy (BIOS)” mode rather than UEFI. Once I did that, the installer was able to use the default startup option (rather than needing to use nomodeset to see any text as described by OP).

I’m not sure if the laptop (a Lenovo 100S) just has a bad UEFI implementation or it is age/spec related, but forcing BIOS mode rather than UEFI allowed me to launch the live desktop and installer.