Installed. Reboot. update-notifier failed

Right after seeing the error message I ran the command without issue.
“wget” service failed. Curious why it passed after I ran it to completion.

Could you give us the output of:

pacman -Qi wget

╭─joekamprad@empowered64 ~  
╰─$ LANG=C yay -R wget                                                                                    1 ↵
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing wget breaks dependency 'wget' required by eos-update-notifier

:stuck_out_tongue_winking_eye:

1 Like
$ pacman -Qi wget
Name            : wget
Version         : 1.20.3-3
Description     : Network utility to retrieve files from the Web
Architecture    : x86_64
URL             : https://www.gnu.org/software/wget/wget.html
Licenses        : GPL3
Groups          : None
Provides        : None
Depends On      : glibc  gnutls  libidn2  libutil-linux  libpsl  pcre2
Optional Deps   : ca-certificates: HTTPS downloads [installed]
Required By     : eos-update-notifier
Optional For    : None
Conflicts With  : None
Replaces        : None
Installed Size  : 2.88 MiB
Packager        : Evangelos Foutras <evangelos@foutrelis.com>
Build Date      : Mon 04 May 2020 10:28:21 PM PDT
Install Date    : Thu 07 May 2020 04:09:01 PM PDT
Install Reason  : Explicitly installed
Install Script  : No
Validated By    : Signature

$ pacman -Qi wget installed it. I’m curious from first message. I no longer get that error even before I installed ‘wget’

It may be caused by a temporary github problem. Eos-update-notifier is trying to download a file with wget from github, and if the download fails, that error message is shown.