Installed Keepassxc, It Won't Open [Solved]

I’ve installed, uninstalled and reinstalled Keepassxc but it won’t open. I have rebooted my laptop a few times too and my system is up to date, running xfce. The Keepassxc looks to have installed successfully but it just doesnt open. I’ve tried from the terminal and from the main menu. Any ideas what I can do?

When you run it from the terminal, do any errors show up in the terminal?

Yes I get this
keepassxc: error while loading shared libraries: cannot open shared object file: No such file or directory

Did you update your system before you installed it?

If you install software without updating first that can cause some serious havoc.

So, in summary, try updating your system and rebooting.

sudo pacman -Syu

I think I did. I just updated and rebooted again but Keepassxc still won’t open. Getting the same error.

Did you happen to install the git version?

Can we see the output of

pacman -Qs keepass

I wanted to ask the exact same question. There are some keepass packages in the repositories. Only one is from the official repository. The rest is from AUR. The one from the official repository is the one to be installed. This runs flawlessly.

yay -Qs keepassxc
local/keepassxc 2.5.4-2
    Cross-platform community-driven port of Keepass password manager

Not as far as I know. Just a straight forward install via Pacman keepassxc 2.5.4-2

tom@tom-endeavour ~]$ pacman -Qs keepass
local/keepassxc 2.5.4-2
Cross-platform community-driven port of Keepass password manager

Well i just installed it with yay -S keepassxc and it’s working on xfce.

I figured an install from one of the official repos would be a better bet than the AUR. In fact I didn’t even look at the AUR

Seems like json-c is missing. Install that one and try again.

1 Like

Yay! This solved it. I had tried libjson-c earlier but that wasn’t it.

Thank you everyone!

You can check which package owns a file(s) with:
sudo pacman -Qo /path/to/file

sudo pacman -Qo /usr/lib/ in your case.

That can help to solve problems like this one, but better to just always update the system before installing anything.

I just checked. It’s not a dependency of keepassxc. Maybe should be added there.
So it must have been drawn as a depency from another package on our systems.

1 Like

It’s probably yubikey-personalization.


That package is indeed installed on my system. :wink: