Installed Fonts in XFCE-Terminal Have Spaces

I’ve installed some fonts and put them in /usr/local/share/fonts and reloaded the fonts cache. I set them as my default fonts in xfce settings->appearance->fonts and they show up perfectly fine. I go in the xfce terminal preferences and they are not listed and they do not show up in the list of fonts. If I check use system font it shows up with a bunch of spaces in between each letters. The default fonts not any of the ones I downloaded show up fine even when checking use system font, but they are also listed in the xfce-terminal. It is not specific to one font, but all downloaded fonts.



You need to use monospace or fixed width fonts in the terminal. Others will not display correctly.


Did you close, then reopen your terminals?

Learned something new today, thank you Dalto! :partying_face: I installed one of those fixed width fonts and it worked like a charm.

I also noticed that after restarting my whole DE there would no longer be spaces in between every letters, only between specific ones like “a” and “i”. The fixed width font worked right away though, no need for restarting XFCE or anything.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.