Installed EOS update and now PC won't boot

I’ve just installed the latest EOS grub update and rebooted, but now my computer won’t show the OS selection screen and just dumps me at the grub prompt.

Any suggestions? Thanks.

If the issue is caused by the update to the Grub package itself, you could try downgrading it to the previous version by using the downgrade command line tool.

In order to do so, you would need to boot into your Live USB and chroot into your installed system. Once in the chroot environment, issue the following command:

downgrade grub

Use the arrow keys and choose the previous version of Grub and press enter.

You could as well regenerate your grub.cfg for good measure:

grub-mkconfig -o /boot/grub/grub.cfg

Next, type exit and reboot the system.

Alternatively, there is a new Grub package in the Testing repo.
You could try installing that instead and see if that one would resolve the issue.

For how to chroot:

Did it show any kind of error like “out of memory” etc? I had out of memory errors after latest grub update and only working solution was to use grub without any theming.

There has been several topics about grub errors in last few days like this one

Only the grub update or you ran all updates? Did you manage a grub pacnew file and replace the old one?

Please drop to a TTY and provide complete input and output of

pacman -Syu

Thanks for the replies. In the end I decided it was quicker to backup and then reinstall EOS. This has now brought back the OS selection screen but before that it always displays two ‘error: out of memory’ messages.

1 Like

I guess the package cache grew too much.

You can set up the package cache manager from the Welcome app that will keep the cache from growing too much.

I tried clearing the package cache and regenerating grub, but it didn’t make any difference.

The problem seems to be that grub is struggling to display the default EOS theme for some reason.

Sure it is not related to nvidia, and the latest kernel (19.3)?

My PC uses AMD Vega (amdgpu).

I had this same error after grub update and I don’t have anything Nvidia related on my system. And same thing happened also with my other Arch install if I used any grub theme.

You guys haven’t been using grub-customizer?


What was your solution to it then?

To use stock black/white grub theme.

That is quite different from not being able to boot at all.

Well It did not boot further than UEFI flash and then it pushed out of memory error. @endbob mentioned that he also saw that error.

Guess I was somewhat OFF then, sorry.

Oldtimer with old HW.


The strange thing here is that I haven’t seen the error after restoring an older Endeavor OS installation and I can even use other grub themes now without problem.

But if I wipe my disk and do fresh Arch install with custom grub theme my system wont boot :thinking:

Could it somhow relate to the new kernel? 19.3 has made some jumps, apparently?

Maybe because install that I restored was on 5.18.