Installed EndeavourOS over Manjaro, dual boot to Windows gone

(I hope this is the right category)

Current situation is the boot menu and EndeavourOS is fine. Only issue is Windows 10 is not listed on the boot menu, after installing EndeavourOS onto my Manjaro partition. And I can still boot into Windows 10 using a “grub rescue” USB I’ve created (can’t remember where I found it), but it scans for bootable partitions, and I can choose the 2nd “Microsoft” looking one, and it boots into Windows 10 just fine. I just need to hook this up in the Grub menu, and I’m not having any luck working out how to do it.

Previously I was dual booting Manjaro and Windows 10. I did it the “right” way, installing Windows 10 first, then installing Manjaro with the “alongside” option. This created a correctly operating dual boot menu. But one day, Manjaro got into a non-booting state after an update. So after spending a day trying to fix it, figured I’d take the opportunity to try EndeavourOS.

I booted in UEFI mode from the live USB of EndeavourOS (and I did use UEFI boot when installing both Windows and Manjaro previously). When installing EndeavourOS, I confirmed the installer said “EFI” on the top left.

The problem seems to be that, when choosing the “install alongside” option, EndeavourOS has re-created a boot menu that just has EndeaveorOS and didn’t add Windows 10 to the list as well. I’ve read some things that gave me the impression that it doesn’t do everything for you, and this is OK, I’d just like to know what to do.

I’ve added an entry to 40_custom (you can see in the info below), but I don’t know how to confirm “(hdi1, 3)” is the windows partition as Grub sees it. I couldn’t find instructions to boot into a Grub prompt to confirm what it sees my drive labels as. AFAIK, Grub2 uses 1 based numbering, eg. hdd with Grub on it is hd1, and 3rd partition is 3. The path to the Windows partition (with Linux drive mounting syntax) is /dev/nvme0n1p3. Partitions 1 and 2 are boot stuff, that’s all I know.

Here’s some info I collected that I hope helps diagnose the info, from the handy EndeavourOS welcome screen buttons;

Hello @Domarius

You have to enable os-prober in the default grub file and i think os-prober needs to be installed also.

sudo pacman -S os-prober

Edit the default grub file in


You have to add or uncomment the line and add false


Then save the file and update grub

sudo grub-mkconfig -o /boot/grub/grub.cfg

Then reboot.

Edit: You better get rid of the changes you made previously though to the 40_custom file.


Oh s***, that was the missing piece of the puzzle - os-prober wasn’t installed! I read that exact same solution so many other times on other pages, but none of them mentioned you might need to install os-prober, and I wasn’t aware it was a seperate program, I thought it was just another grub command that’s a part of grub. And I got no error messages about it missing at any point, when updating grub etc.

With os-prober installed, updating grub found the Windows install no problem! Now I have something to update my Linux notes file with, for future reference. Thanks @ricklinux :slight_smile:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.