Installation problems with Radeon RX 7600

It is possible that the firmware on the ISO is older than what is required for your GPU.

1 Like

How do you have the monitor hooked to the computer? Is it Hdmi and it’s connected from the 7600 to the Monitor? Hopefully you aren’t connect to the motherboard Hdmi port as that is only for onboard graphics.

Edit: Also as @dalto mentioned this could be a possibility since the 7600 series cards just came out recently.

Yep, the screen is directly connected to the graphics card via HDMI.

So, maybe I just need to wait until the ISO gets support for the 7600?

Do you have another GPU or does your machine support integrated graphics?

If so, you could install using that and then after you install and update you will have the newest firmware and can switch back.

When I had this same problem, I was attempting to switch over to Linux from Windows.
I was running Windows 10 on an old Dell Precision T5610 workstation I got off ebay. I had a Radeon RX 5600 XT in the system. Everything ran great in Windows. Stable. No issues.
I really wanted to install EOS so I got everything ready and then tried to boot from the install USB drive.
It froze exactly like NichtElias described.
I tried Ubuntu, Fedora, Arch base and they all did the same thing.
I removed the Radeon RX 5600 XT and put in my old Geforce 1060 and EOS booted right up.
I put the Radeon RX 5600 XT into my older machine running an Intel i7-3770K on an ASUS motherboard, and EOS booted right up.
It was the combination of that Dell machine with the AMD card that just did not work.

I am currently typing this from the i7-3770K machine with the Radeon RX 5600 XT running EOS.
I am also running EOS on the Dell machine with the 1060 card. All stable running great.

I can’t imagine what it is about the combination of hardware in the Dell that the Linux Radeon drivers just do not like.
Yes I run old super outdated hardware. I hope to upgrade soon.

I have created new ISO for you to try with the latest firmware and packages. If you would like to try it to see if it will boot on the RX 7600 i can upload it for you to google drive and provide you the link. Let me know if you would like to try this and I’ll upload it and let me know you have it downloaded.

It’s here now:

Edit: Link Removed

1 Like

Thanks, I’ll try it tomorrow

Were you able to download it?

Edit: I just don’t want to leave the link up too long.

I started the download now. It’ll take ~20 minutes

Edit: for some reason the download failed, trying again now

1 Like

Okay…hopefully it downloads for you.

Yep, it’s fully downloaded now

Okay… i hope it will work for you?

1 Like

Finally, it works! Thank you so much!

1 Like

If a rebuilt ISO fixed it, that means it was the firmware package that was the problem.


you can share this also:

it is automatically rebuild currenzt ISO every week and release it.


Just wanted to check up on your install? Hopefully everything is working well for you after getting it installed with that ISO.

1 Like