Installation-problem bootloader

Hi, because EOS supports BTRFS + LUKS, I want to give it a try. One Installation on a laptop i5 and 1TB SSD works well, I started to install it on another laptop with i5 and 2 TB SSD.
Out of five attempts, one worked, but since I could not enter the login password correctly on the desktop, I have made five unsuccessful attempts. The error message is:
"The bootloader could not be installed. The installation command

grub-install -- target=x86_64-efi --efi-directory=/boot/efi -- --force

generated error code 1."
Has anyone an idea to install EOS on this device? I would be very happy.

Looks like there are typos in the command, probably should be:

grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=EOS --force

Note that I didn’t test this, only fixed typos I found… So check carefully!

See also: man grub-install

by that means you got this error inside install process from calamares?
so it could be you add the typo by copy the line over manually?
If installer fails with this error it is mostly related to

  1. wrong setup for ESP partition while creating manual partitions
  2. an issue while reusing an existing ESP p.e. from an OS already installed in dual boot setups.

yes, i have not changed or added anything to and in calamaris.
Since I urgently needed a working Linux, I made tests with arco-linux and manjaro. The same error occurred.
Only when I installed “without swap” was the installation finished, now in Manjaro.
Then until the next time and Thank you!