Installation on VB does not start

I tried to install EndeavourOS Gemini on Virtualbox; the installation finish correctly but, at the restarting of the VM the installed system do not start… only a cursor blinking.
I tried to install previous version (Galileo) and all works fine…
Any solutions?

As EndeavourOS is a rolling release distro, you can update the system, and everything is fine.

Login with x11 not wayland
Btw welcome to the forum @pimpoli


Alternatively enable 3D acceleration in the VM.


This will be the issue i see the same in case installing kde/plasma defaults to wayland what needs 3d enabled in settings.
LiveSession is still running X11 session, so the issue applies on first start of installed kde.

1 Like

How to make it? I cannot login, the grub screen does not start at all!

To login under X11 on SDDM (the login screen) there is an option on the bottom left
To enable 3d acceleration if you wish to use Wayland

1 Like

Not too sure about this, just noticed you said GRUB doesn’t start

I cheked 3d acceleration… nothing. As soon as start vm this is the result:

I explored root of the installation vdi and there is not /boot/grub/grub .cfg

At install, the default bootloader is systemd-boot. Unless you selected something else, that’s the one with UEFI (on EFI systems).

On MBR systemd-boot is not available, so the default is grub.

Edit: on Virtualbox the default is MBR (unless you select EFI support), so you may have grub.

1 Like

On my pc there are only linux system, so I disabled secure boot on bios. I want to make an installation without efi or uefi… I created on VM 2 parftitions, one ext4 for root and one swap (MBR partition table). I indicated to install grub on /dev/sda.

The install should be very straightforward to a Virtualbox VM. In most places you can select the defaults, and you don’t have to pre-partition the virtual disk since the installer can do that.

So is it possible that you overdid some settings?

You’d select the root partition size, source ISO, and RAM, optionally also video memory size. That’s about the minimum that should work.
If it doesn’t, then maybe the USB stick is not properly burned?

I downloaded the ISO and use that, not usb stick. The only settings I changed from default are Hd dimension (25 GB), RAM (4096) and processors (4). Then I maked partitions fron gparted in the live (MS-DOS partition table, 2 GB swap and 23GB ext4 root) and I launch calamares. The installation end without issue, I restart and… blank screen with a blinking cursor.
The same installation with previous version of EndeavourOS (Galileo) was fine.

When you boot the VM, what does it do before the picture above?
Can it output anything before that?

Does it stop before or after giving the account password?

Nothing before that. No boot. Immediatly the blak screen.

checked the bootorder settings in vb ? rfs is flagged as boot device?
And in case using Bios mode from what i remember vb is always booting back into the ISO boot screen by default…

Can you share the installation log?
In the end of installation in the VM, just before reboot, give terminal command

cat /home/liveuser/endeavour-install.log | eos-sendlog

and show the returned address here.
just replicated the same thing here in virtualbox i think… no grub is installed… on a Bios VM

    Starting job "eos_bootloader" ( 32 / 40 ) 
[PYTHON JOB]: Found gettext "de_DE" in "/usr/share/locale/de_DE" 
    .. Running QList("pacman", "--noconfirm", "-Rcn", "mkinitcpio") 
    .. Target cmd: QList("pacman", "--noconfirm", "-Rcn", "mkinitcpio") Exit code: 1 output:
 error: target not found: mkinitcpio
    .. Running QList("pacman", "--noconfirm", "-S", "grub", "eos-dracut", "os-prober") 
    .. Running QList("dracut", "--force", "--hostonly", "--no-hostonly-cmdline", "/boot/initramfs-linux.img", "6.9.2-arch1-1") 
    .. Running QList("dracut", "--force", "--no-hostonly", "/boot/initramfs-linux-fallback.img", "6.9.2-arch1-1") 
14:43:31 [6]: virtual void Calamares::JobThread::run()
    Starting job "grubcfg" ( 33 / 40 ) 
[PYTHON JOB]: Found gettext "de_DE" in "/usr/share/locale/de_DE" 
14:43:31 [6]: virtual void Calamares::JobThread::run()
    Starting job "windowsbootentry" ( 34 / 40 ) 
[PYTHON JOB]: Found gettext "de_DE" in "/usr/share/locale/de_DE" 
    .. Running QList("grub-mkconfig") 
[PYTHON JOB]: "No Windows entry found by os-prober" 
14:43:32 [6]: virtual void Calamares::JobThread::run()
    Starting job "bootloader" ( 35 / 40 ) 
/usr/lib/calamares/modules/bootloader/ SyntaxWarning: invalid escape sequence '\$'
  prefix, generator_name = re.match("(.*)\${([^}]*)}$", name).groups()
[PYTHON JOB]: Found gettext "de_DE" in "/usr/share/locale/de_DE" 
WARNING: [PYTHON JOB]: "Non-EFI system, and no bootloader is set." 
14:43:32 [6]: virtual void Calamares::JobThread::run()
    Starting job "services-systemd" ( 36 / 40 ) 

I bet this is something caused by using prepartitioned device, what is not reformatted by calamares… as it seems to asume no bootloader is selected wrongly.

If you are repartition or use autopartition method sit does not happen.

Thanks for that I had not tried enabling 3D acceleration to see if EOS would start using wayland in virtualbox and it works.

1 Like