Installation Not Working

I’ve been stuck at 14% for the past 30mins. This is my second attempt, as the first one outright failed. Any idea on how to solve this? It was working properly on the VM, I’m guessing that it’s network problem but i can access and view webpages normally

Welcome to EnOS’ forum @Sololvl0!

Not sure if this might help but you could try to update the mirrors from the Welcome app which pops up right after you boot into the live session.

Can you scroll up inside the install log and see what the last thing was it did?

Otherwise cancel the installation, reboot and try again. And, like @pebcak said, update mirrors is always a good idea.

1 Like

Tried it after installed failed for the first time. Now it’s stuck here.

1 Like

I just cancelled the install for the 3rd time. I will update the post after trying again
It just crashed at this.

And now the Calamares won’t start up.

==> update-mirrorlist: country code not found on Arch mirrorlist

I’m not an expert on reflector. Seems to me like it fails and then stops because of your country code. Did you select a specific language besides english? If yes, could you try to reboot and install with everything being set to US language?

I’ve restarted it like 5times and changed the mirror list , now the Calamers won’t even start.

That’s weird. There is a possibility the ISO is faulty from the download or there were errors when creating the bootable USB stick.

Try to shutdown instead of reboot (if you didn’t already do it). If that doesn’t work, I would download the ISO again, verify the checksum according to this page (at the bottom) and create the bootable USB stick again with the given install guide. Did you verify the ISO when you first downloaded it?

I didn’t verify it but I’ve installed the same ISO on Virtual Box and it worked and everything was fine. Maybe is it because I’m using Ventoy for booting? Did anyone else use Ventoy?

There were people on this forum using ventoy, that I do know. So it should work. But if you have a spare USB stick, maybe you can try it without.

I’m not so sure if the mirrorlist actually gets saved to the USB stick when updating. So it could be reflector making a mistake results in you not having an okay mirrorlist file. Maybe you could show us what is inside /etc/pacman.d/mirrorlist in the live environment.

You could also try to manually update the mirrorlist and see if there are any output errors inside the terminal.

reflector --latest 5 --sort rate --save /etc/pacman.d/mirrorlist

It’s just stuck here:

I don’t think it has anything to do with the installation part. I think it’s the mirror’s problem. Any idea on how to fix them?

This happens after running the command:

I wonder if you need rsync installed for reflector to sort by rate :thinking:

You could also generate the mirrorlist manually here:

Remove # from the beginning of the server line(s) and put it in /etc/pacman.d

Still the same. I’ll try downloading the ISO again

There also seems to be something wrong with your connection, if you look at the package loss. Maybe restart your router?

The “permission denied” error probably happens because you need to run it with sudo. It tries to edit the mirrorlist file but can’t do it without root rights.

Ok but I think it’s the network problem too. But it works normally on the Virtual Machine. Any idea on how to solve this?

Can you install and update programs inside the live environment?For example

sudo pacman -Syu youtube-dl

or something else?

Yes I can use pacman. I’ve installed video recorder using pacman and it’s working fine.