Installation Issues for Dual-booting with Windows

I wanted to try endeavourOS so i flashed it on a USB And booted on it, But When im booting it tells me that my main drive that has windows is likely to fail,i ignored it and continued on the installation
but when i tried replacing a unallocated partition with EnOS it failed i tried the installation again ,same thing
but then i decided to see a solution online and someone said to reflash the iso so i restarted the system to boot onto windows and flash the drive but my windows drive isn’t there, i booted into my bios and its not there on the boot order,
so at a last attempt i booted the enOS tried some commands to mount the drive from the internet,
yeah that didnt work but i noticed that the drive still exists in the partition manager,
i restarted on my bios, reset my bios settings but then suprisingly windows booted,
but the question is if i try to install enOS again will the same thing happen or worse?

I have no idea what your question actually is… perhaps you can clarify your need for the slow learners in the crowd, like me.

The one item that comes to my mind from your note is did you bother to run disk diagnostics on your drive after seeing the initial error? If so, what was reported. Please post the details.

Also please run your EOS live USB and enter the following (or similar) in terminal. Post the results here so people can see what you are running:

inxi -Fxxz

In addition to what manyroads asked for, I would also suggest you post the output of this command from the live USB:

sudo fdisk -l

Lowercase L not 1 or i

share the installer logs and we would be able to see what is the issue…

I Am Guessing This is What You Wanted

Fixed: It turns out that the issue was that my drive had four partitions. When endeavourOS attempted to create a fifth, it failed because MBR can only support a maximum of four partitions “According to what i found”. so, I combined two partitions in Windows Disk Manager and swapped out the third partition for endeavourOS, and this solved the issue


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.