Installation fails at grub installation

I love EOS and installed it a few times in the past without any issues.
Now I’m trying to install it on an old laptop (Toshiba Satellite L10W-B-101).
The system installation itself runs fine without any errors but it fails at the very last stage when it tries to install grub with following error code:

The bootloader could not be installed. The installation command grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=endeavouros --force returned error code 1.

Here’s the full install log:

The error occurs with online and offline installation and with different DEs.

The disk I tried installing to was a completely new/blank SSD.
After 2 fails, out of curiosity I tried installing Linux Mint on the same disk which worked completely fine including the bootloader setup.

But I’d rather use EOS. So if anybody got any ideas on how to fix this, I’d appreciate it.

Could not prepare Boot variable: Input/output error
grub-install: error: efibootmgr failed to register the boot entry: Input/output error.

Is your EFI partition full?

No I don’t think so.
It’s a fresh install. Used the ‘Erase Disk’ option at install.
780 kb of 300 mb are used on the partition.

What’s the output of

efibootmgr -v


BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 0001,0000,2001
Boot0001* UEFI:  USB	PciRoot(0x0)/Pci(0x14,0x0)/USB(6,0)/HD(2,MBR,0xe1eebc4a,0x728c000,0x10000)..BO
Boot2001* EFI USB Device	RC

Sometimes too many entries in NVRAM might cause some issues. Doesn’t look like that in your case.

You could try installing the boot loader manually.

You would need to chroot in your installed system and run one or the other of the following commands:

grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=EndeavourOS --no-nvram --force


grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=EndeavourOS --no-nvram --removable --force

Hopefully you will get the following output:

Installing for x86_64-efi platform.
Installation finished. No error reported.
1 Like

Thank you a lot! The second command worked, and I get a grub menu now…


Now I’m stuck on ‘Loading initial ramdisk …’ when trying to boot.
Completely stuck no tty etc. is working.
It’s same for both kernels lts and ‘normal’ one.

1 Like

Try chrooting again and run:

mkinitcpio -P

when done


and reboot. Hopefully this will resolve the issue.

1 Like

Unfortunately that didn’t solve the problem.
Still stuck on init ramdisk on both kernels.

That was unfortunate!

I am running out of ideas. You might want to try reinstalling all the packages.

In chroot:

pacman -Qqn | pacman -S -

Can’t guarantee that it would work but might be worth a shot.

1 Like

No luck with that unfortunately.

But thank you nontheless for your help! At least I’m a step further now :slight_smile:

1 Like

Are you sure you have disabled Secure Boot?

1 Like
    Skipping non-emergency job "prepare post-installation cleanup tasks ..." 
2022-03-04 - 15:13:23 [6]:     ..  Skipping non-emergency job "running post-installation cleanup tasks" 
2022-03-04 - 15:13:23 [6]:     ..  Skipping non-emergency job "reset 90-mkinitcpio-install.hook" 
2022-03-04 - 15:13:23 [6]:     ..  Skipping non-emergency job "services-systemd" 
2022-03-04 - 15:13:23 [6]:     ..  Skipping non-emergency job "Saving files for later ..." 
2022-03-04 - 15:13:23 [6]:     ..  Skipping non-emergency job "copy logs and files from host to target" 
2022-03-04 - 15:13:23 [6]:     ..  Skipping non-emergency job "umount"

the not running of this tasks is the issue in addition…

1 Like

Yes it’s disabled.

Do you have any idea why those got skipped?