Installation failing repeatedly

I’m trying to install EndeavourOS on my system using the latest ISO: EndeavourOS_Artemis_nova_22_9.iso. However, the installation fails after a few minutes. I tried it 4-5 times and I get the same error every time. Can someone help me find out what the issue is? The calamares log is available at the following termbin link:

P.S. I’m not new to Linux, or even Arch Linux. I’ve been using Linux as my daily driver for the past few years. I started using EndeavourOS about a month ago and, for reasons not relevant to this issue, I decided to reinstall EndeavourOS today.

See the topic here - Package Manager error preventing me from downloading endeavouros

You need to uncheck the packages ipw2100-fw and ipw2200-fw in the installer.

EDIT: Also, welcome to the forum :smiley:


This should be fixed now for the most recent ISO.

1 Like

Thank you so much! I did search the forum for this issue but I got only this: Installation failed - package manager error: The package manager could not make changes to the installed system. The command <pre>pacman</pre> returned error code 1. Since the solution didn’t apply to my case, I decided to post here.

Thank you again!

How recently was it fixed? I downloaded the ISO using the torrent about 3-4 hours ago.

About 10-ish minutes ago.

It doesn’t require downloading a new ISO.

Thank you! That fixed the issue. I think I forgot to reply to you.

1 Like

Okay. So what about the 2 packages that I’d unchecked? Should I manually install them using pacman after the OS has been installed?

No. Those packages were removed from the repos.

It is firmware for specific Intel wifi adapters. If your system works without them, you don’t need them.

1 Like

So the fix that you were referring to was the fact that Calamares no longer has those 2 packages under Network and no intervention on the part of the user is required, right?

1 Like


1 Like

Okay. Thanks for the clarification, @sradjoker!

That error message is very near the end of the log link you posted.

Yes. I did see that and I also knew that it was because one or more packages were missing. But I didn’t know what packages they were in this particular case. I tried unchecking the LTS and Zen kernels; another time I tried removing ‘Accessibility Tools’ and when none of them fixed the issue, I came to the forum.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.