Installation failed The package manager could not make changes to the installed system. The command <pre>pacman</pre> returned error code 1

Hi, trying to install but ran into this roadblock. Despite everything else saying that this drive is completely wiped, the installer doesnt seem to think so? anybody got any ideas? Ive tried reinserting the usb, restarting etc etc and after probably more than 10 tries, nothing.

We would need to see the log to know for sure.

Be sure you are using the latest ISO. This will definitely occur if you use an old ISO due to the removal of some firmware packages from the repos.

thanks for the advice on the iso, currently trying to replace the iso but may not be able to until later in the week so looking for other solutions. Here is the log:

On the screen where you can check the packages you want to include find ipw2100-fw and ipw2200-fw and uncheck them. Those packages have been removed from the repos.

…i dont see anything much like either of those in the package selection section. I did also look inside the various packages i have selected and they dont seem to be in their either…

They should be under eos-base-group:

Appreciate your help, i eventually did find it, tried it but unfortunately got the same error… (new log if its any use:

1 Like

error: target not found: grub-tools

Remove this one as well: grub-tools

Try to boot on the live usb. Launch gparted and create a new GPT partition with device create partition table and select GPT. Then close gparted and run the installer and erase disc select file system type and install.

Edit: Hopefully this clears the disk and creates a new partition table and installs.

Edit2: I assume you want to wipe the whole disc?

old ISO indeed

This worked! Help much appreciated, have a great day.

1 Like

I did consider reformating manually although going to g parted prompted it to say it was unmounted and empty… I think it was something to do with the iso.

I didn’t realize you were using an older ISO. That makes sense now. Glad you were able to resolve the issue.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.