Installation Failed , error in job "bootloader" when using extended partition

Hi, I am trying to install EndeavourOS on an extended partition
Here is an overview of the partitions setup:
/dev/sda4 extended
– /dev/sda6 fat32 /efi
– /dev/sda5 ext4 /

I am installing on an extended partition since for some reason i can’t use gpt, i’ve disabled legacy boot from my BIOS.

Every time the installation process reaches the bootloader step, it’ll fail with the following message:
Installation Failed
Boost.Python error in job “bootloader”.

No such file or directory “/tmp/calamares-root…/loader/loader.conf”

I read somewhere that i should’ve checked the format option, but there was no such thing.

The EOS version i am installing is the cassini nova.

1 Like

It you have a disk with ms-dos/mbr partition table, then you would need to install in MBR/Legacy/Bios mode.

For installing in UEFI mode a GPT disk is mandatory.

:warning: Please note that this will overwrite the MBR of your disk so in case you have already Windows on this disk, you might want to make a recovery disk for it if/when you will need to restore its bootmgr.

Hi, I’m not sure how i could switch the installation mode into MBR ?.

i thought i was already on MBR mode

Also I have a windows, and tried installing ubuntu and fedora before trying my luck with EndeavourOS, so i’m not sure if once the installation succeed i will be able to boot into my windows?

Enable this again and boot up your USB in Legacy/Bios mode.

Yes. Grub will pickup your Windows install.
It might be that you would need to enable os-prober for it but that is easily done.

would there be a performance difference in disk operations if i were using MBR instead of GPT ?

I wouldn’t think so.

thanks, i’ll try again, but before that, is the partition setup good enough so far ?

You don’t need that FAT32 partition for a Bios/Legacy mode install. Make just one EXT4 partition in that “Extended Partition”.

As said before, make a recovery disk for your Windows (in your Windows).


I would be more concerned with MS doing something that would make linux non bootable. I would recommend you get another drive for linux or use virtualization.

however to get to the issue.
What boot loader are you trying to install?

1 Like

i tried the systemd-boot

Systemd-boot works only with UEFI.

You would need to use Grub.


difference isn’t going to be perfomace persay as it is limits.

MBR is limited to 4 partitions to a disk where GPT is limited to 128 partitions to a disk. Also any ssd or nvme drives that are over a terrabyte should be gpt as MBR has a size limit (not sure of what it is anymore)


Systemd does not support Legacy boot. (MBR / Bios) systemD only supports EFI. so install grub not systemd-boot

1 Like

i see, thank you

i’ll try again using MBR mode, with grub bootloader and without FAT32 /efi partition, thanks.

Good luck!

1 Like

Another lesson: in a legacy BIOS node, installation according to the MBR scheme is supported, while in UEFI mode, GPT is supported. Perhaps the confusing thing is that you can often choose both in the BIOS.

yeah, i had 2 options for booting from my usb, one is prefixed with UEFI, i’ve always chosen this one previously, and maybe that’s why my ubuntu and fedora installation attempts failed too.

Awesome!!, it’s working now, thanks a lot @pebcak @thefrog @zoli62


Great! Congrats!

Enjoy your system and welcome to EnOS’ community @nortnb !

:enos: :handshake:t5:

1 Like