Installation Error - mkinitcpio

Hi All,
My first time trying to install any Arch based linux. I have a Lenovo Thinkpad T420, on which I am trying to install endevour OS. The Laptop already has W10 and Ubuntu on it. I am trying to install Endeavour on some free space I have on my secondary drive.
So in the installer, I set the boot/efi and the / mount points and then start the installation. The installation goes well till it start to make the intramfs. Here it fails with the message
ERROR: Installation failed: “External command finished with errors.”
… - message: “External command finished with errors.”
… - details: Command mkinitcpio finished with exit code 4.
From the log
==> Building image from preset: /etc/mkinitcpio.d/linux.preset: ‘default’
→ -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
==> Starting build: 5.13.12-arch1-1
→ Running build hook: [base]
→ Running build hook: [udev]
→ Running build hook: [autodetect]
→ Running build hook: [modconf]
→ Running build hook: [block]
→ Running build hook: [keyboard]
→ Running build hook: [keymap]
==> ERROR: Hook ‘plymouth’ cannot be found
→ Running build hook: [filesystems]
→ Running build hook: [fsck]
The system is using UEFI and has EFI partitions.

I am not sure what the issue might be.
Can someone help me out ? .

Did you add the plymouth hook to /etc/mkinitcpio.conf without installing plymouth?

Edit: Wait…is that is happening during the install?

1 Like

Yes. First time install.

Which ISO are you using and are you doing an online or offline install?

we do not have this set in mkinitcpio.conf

So to see what happens we need some more info about the exact install method chosen DE e.t.c. best would be the full installer log:

cat ~/endeavour-install.log | eos-sendlog

1 Like

Hi Guys,
Thanks for your reponse.

Here is the install log

I am doing a offline install and using the XFCE (endeavouros-2021.08.27-x86_64.iso)

Uhh…did you use manual partitioning and choose to not format the partition? You appear to have both Manjaro and EOS installed into the same partition.

1 Like

Yep. That was it.
I used gParted and formatted that partition. Then I tried the install again. It worked !!!

Thanks everyone for your help.

1 Like