Installation crash

Hi, I was trying to install the recent iso Galileo, and I faced a issue, every time when I tried to install, the installer crashes on the disk partitioning section and I can’t continue to the next sections.

  • I’ve tried to select grub or systemd boot loader
  • I have 2 SSD disks and 2 Sata disks
  • I just have installed Manjaro in one SSD and I want to install Endeavouros into the other SSD
  • I have deleted all the partitions inside one SSD.

The logs are here installation log

Could you give some advice?

Hi @danfercf ,
"WARNING: system is EFI but no EFI system partitions found. "
Perhaps creating a FAT32 partition with KDE Partition Manager manually (flags: boot, efi), size 1000 MB and starting again the installation after reboot helps.
EDIT: I removed all partitions from an USD stick and selected that with Erase option installation succeeded. Originally target USB had msdos and installation created gpt partition table.

I will try it, but, can this affect my Manjaro’s installation?

Hi! Seems you have deleted partition table even. You have to initialize ssd by creating partition table first GPT/MBR (in gparted for instance) and after that try to install again.

if it’s a separate SSD it will not spoil your Manjaro. As for the creation / deletion of the partition table on this ‘other SSD’ I tried this Galileo iso with the Erase option. It created a gpt type partition table.
Double check which SSD you select in Calamares. I used ext4 and GRUB. It worked.

Seems Manjaro is installed in legacy mode?
Aka CSM or legacy /Bios ?
Could be also your Firmware is still set up to CSM legacy boot mode for usb… check this first.

And the sefest way is to create a placeholder partition on the empty drive if you want to use the full harddrive… use erase option on partiiton screen and make sure selecting the right drive.

You can check about boot mode used from LiveSession by executing this command:

efibootmgr it will show boot entries in case it is booted on efi mode and an error message if not …

Yesterday I’ve installed another SO (Nobara) in the same disk, and the installation went without any problem, I think the problem is on EndeavourOS installation. On the partition section I’ve tried several times with the erase option, I tried the manual option also, but I faced the same problem, A popup appears, it says Scanning drives, after some time all the screens disappears and I just have the welcome screen again

what does this show ?


looks like install media is corrupted or not fully synced to the usb.