Install textext for inkscape with a vanilla texlive


I’ have texlive 2023 installed. As I try to install the textext extension for inkscape, from source, i met the error:

textext-1.9.0/ $ sudo python3 --inkscape-extensions-path '/usr/bin/inkscape'
[sudo] Mot de passe de jeanpat : 
[TexText][SUCCESS ]: + [Succ] TexText requirements
[TexText][SUCCESS ]: /-and-* [Succ] Detect inkscape >= 1.3
[TexText][SUCCESS ]: |      inkscape=1.3 is found
[TexText][SUCCESS ]: /-and-+ [Succ] Detect *latex
[TexText][SUCCESS ]: |     /--or-* [Succ] `pdflatex` is found at `/usr/local/texlive/2023/bin/x86_64-linux`
[TexText][SUCCESS ]: |     /--or-* [Succ] `lualatex` is found at `/usr/local/texlive/2023/bin/x86_64-linux`
[TexText][SUCCESS ]: |     /--or-* [Succ] `xelatex` is found at `/usr/local/texlive/2023/bin/x86_64-linux`
[TexText][SUCCESS ]: /-and-+ [Succ] Detect GUI library
[TexText][SUCCESS ]:       /--or-* [Succ] GTK3 is found
[TexText][SUCCESS ]:       /--or-* [Succ] TkInter is found
[TexText][CRITICAL]: Can't copy files to `%s`: it's not a directory
Traceback (most recent call last):
  File "/home/jeanpat/Apps/TexText-Linux-1.9.0/textext-1.9.0/", line 478, in <module>
  File "/home/jeanpat/Apps/TexText-Linux-1.9.0/textext-1.9.0/", line 160, in copy_extension_files
    raise CopyFileOverDirectoryError("Can't copy files to `%s`: it's not a directory")
CopyFileOverDirectoryError: Can't copy files to `%s`: it's not a directory

I can install textext with yay, but yay install some texlive elements leading to two texlive distro installed.
Any idea where to start?


You can try to install texlive-installer from the AUR and then install textext also from the AUR.
texlive-installer installs only installer script, not texlive itself:

This packages provides the installer of texlive. It also tricks Arch into thinking it has its texlive packages installed.

thanks, I’ll try this

textext is installed but I have to trick it to specify the path to pdflatex (/usr/local …)

Inkscape was recently updated to major version, are you sure your extension is updated to work with it? Make sure that any instructions you are following are for Inkscape 1.3, not earlier.

inkscape 1.3 is installed.

textext was installed with yay textext after yay texlive-installer.

texlive is in
and textext in:

In textext doc,, there’s a way to specify the path at the setup . I don’t know how to edit the path after installation.

Are latex executable files in your system PATH? If so, you don’t need to provide textext with exact path to pdflatex, IMHO.
You can check that with which pdflatex from terminal.
If pdflatex is not found, append /usr/local/texlive/2023/bin/x86_64-linux/ (choose correct path on your installation) to the system PATH.

Hello, sorry for delayed answer. Latex in the PATH:

$ echo $PATH                                              [21:20:12]

The very beginning of my .zshrc is:

# If you come from bash you might have to change your $PATH.
export PATH="$HOME/bin:/usr/local/bin:$PATH"
export PATH="/home/jeanpat/.local/bin/:$PATH"
export PATH="/usr/local/texlive/2023/bin/x86_64-linux:$PATH"

I installed textext from the AUR and it works fine with my local LaTeX installation. The default configuration is OK, I didn’t change any settings. If it doesn’t wotk in your case, maybe there is some other problem unrelated to pdflatex path.