Install Nvidia Vulkan Beta Dev Drivers?

I’m really new to linux so I have very little clue as to what I’m doing. I’m trying to install the nvidia vulkan beta drivers to use the graphics pipeline library for eliminating sutters in Apex Legends. I tried installing using to install 515.49.14 and i removed the conflicts i had with the old driver. Apex Legends crashes instantly though when I try to run it, it doesn’t even open the game. What am I doing wrong? Apparently other people are using these drivers perfectly fine and I was able to run the game before I installed these drivers.

My question basically is, how do I properly install these nvidia beta dev drivers on endeavorOS?

There’s an AUR package, have you tried that?

This doesn’t seem right to me. Don’t even know what hardware the OP is trying to install on. The nvidia vulkan drivers are newer than the latest nvidia? 515.49.14 :thinking:

Yes, but I think I messed something up because I couldn’t get my desktop environment to start and was just left with a terminal.

Also my hardware is:
z590 dark
i9 11900k
rtx 3090
32gb ram

Please post the link from the following command from a tty.

inxi -Faz | eos-sendlog

Have you tried running this to revert to open source nouveau? See if it can get you back to booting to a desktop?

nvidia-inst -n

Edit: You should be trying to install the vulkan package from the AUR which is this one. I think? :thinking:

yay -S nvidia-vulkan
1 Like

Nice hardware btw. Welcome to the purple side!

Also after that mishap with my desktop environment not starting I just reinstalled endeavor and thats when I used the Frogging installer and now I’m just left with apex crashing on startup. I just assume I messed up more stuff since other people seem to be using these drivers just fine.

I’ll try the yay command you put rn.

It’s not the package i would be using. I don’t know what hardware these others you refer to are using this package on? But this is the latest nvidia vulkan drivers from what i see and with the high end hardware you have i would only be trying the official drivers.

Edit: This is coming from the Nvidia site.

So using yay -S nvidia-vulkan to install the drivers leaves me at “Started Accounts Service” during bootup. I can use ctrl+alt+f2 to get a terminal but I never reach the desktop environment

Also using nvidia-inst -n doesn’t work to get me back to the desktop

Did you try the original install with just the current nvidia drivers using nvidia-inst?

Edit: Did you a have a working system and the drivers were installed properly? Would need to see that.

inxi -Ga 

So nvidia-inst doesn’t have the vulkan drivers 515.49.14 although those are on the nvidia website. On a working system this is the output of what you asked


  Device-1: NVIDIA GA102 [GeForce RTX 3090] driver: nvidia v: 515.65.01
    alternate: nouveau,nvidia_drm non-free: 515.xx+ status: current (as of
    2022-07) arch: Ampere code: GAxxx process: TSMC n7 (7nm) built: 2020-22
    pcie: gen: 1 speed: 2.5 GT/s lanes: 8 link-max: gen: 4 speed: 16 GT/s
    lanes: 16 ports: active: none off: DP-1 empty: DP-2,DP-3,HDMI-A-1
    bus-ID: 01:00.0 chip-ID: 10de:2204 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.4 compositor: xfwm v: 4.16.1 driver:
    X: loaded: nvidia unloaded: modesetting alternate: fbdev,nouveau,nv,vesa
    gpu: nvidia,nvidia-nvswitch display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 90 s-size: 542x301mm (21.34x11.85")
    s-diag: 620mm (24.41")
  Monitor-1: DP-1 mapped: DP-0 note: disabled model: BenQ ZOWIE XL LCD
    serial: EBF4L06451SL0 built: 2020 res: 1920x1080 hz: 60 dpi: 90 gamma: 1.2
    size: 544x303mm (21.42x11.93") diag: 623mm (24.5") ratio: 16:9 modes:
    max: 1920x1080 min: 640x480
  OpenGL: renderer: NVIDIA GeForce RTX 3090/PCIe/SSE2 v: 4.6.0 NVIDIA
    515.65.01 direct render: Yes

edited by moderator to add code tags

No the vulkan drivers are in the AUR which I gave you the command to build and install them. Looks like the original install has the correct Nvidia drivers installed and working properly. I take it you had a working system until you tried that other package you mentioned in the original post?

Edit: Also please use code tags around what you post from the terminal it is much easier to read.

So yay -S nvidia-vulkan left me without the desktop environment upon reboot and using nvidia-inst -n and nvidia-inst to install the most recent driver didn’t fix it so I decided to reinstall.

Using the frogging package I mentioned earlier left me unable to boot apex, it would just crash.

I’m on a fresh install again at the moment which is what I used to run inxi -Ga

Also sorry, I didn’t know what the code tags were called.

The code tags are the </> button in menu and you put the output between. Or you can use three back ticks like this ``` or three tilde ~~~ before and after what you paste from the terminal. So if your system is working fine now I don’t know what the issue is with installing nvidia-vulkan. Maybe @jonathon can help with that. I have no experience using vulkan drivers on my Nvidia. Never tried as I’m not a gamer.

Well if I try yay -S nvidia-vulkan it hangs on bootup at “Started Account Service” with no desktop. I want to use the drivers from that command because they offer dxvk’s graphics pipeline library which fixes Apex’s stuttering issue.

The current drivers that I have installed don’t have that feature and the game stutters which is what I’m trying to prevent.

Not sure why it doesn’t boot to the desktop with those drivers? There are the dkms version of the vulkan drivers also. I would try installing them but they don’t support my card GTX 1060.

Also it is my understanding that the Nvidia drivers include vulkan support.

Make sure you have the 32 bit library files installed and try the game again.

sudo pacman -S lib32-nvidia-utils

That worked, thank you.

I’m also not sure if you need these packages also?




I added those when I added the other package as well. I was probably missing only one or two but it finally works. Again, thank you so much.

1 Like