Install failed Boost.Python error in job "mount"

**SORTED! See reply below.

I am possibly a newbie. I did use Ubuntu many years ago until it got too bloated. And I tried Mint, but wasn’t keen. So I am heavily relying on on google. I did search this forum and the internet in general before posting.

I am using a usb stick to install on an ASUS laptop that has windows. I am writing this on a different laptop, so I can’t copy paste things over. I do not currently have a computer running linux.

Downloaded EndeavourOS_Cassini_Nova-03-2023.iso onto this (windows) laptop where I am typing. Checksum checked out. Moved it onto the usb using USBWriter-1.3.

Installing onto ASUS X505BA 1.0 (I got it lightly used in late 2018, so older than that)
3 Gh AMD processor, 1Tb HDD storage, 8GB memory

Got through the entire pre-install setup on the target laptop using the online install.
In the partition tab, I chose the third option - erase disk, no swap.
Seeing as how it is a chcon error, I after I entered my password, I kept the box unticked for logging in automatically and ticked for using the same password for admin.
I got to the install now buttons (yes, yes, I really do want to delete everything and install this).
The first time it failed, I copied the message to the internet by clicking that option. Not sure where it went. It won’t let me into firefox. Yet.

Here is the tiny url from the prompt for the log

This time around, I am just typing the whole error message in here - sorry for any extra spaces or returns or typos:

Installation Failed
Boost.Python error in job “mount”

<class 'OSError'>
[Errno5] Input/output error: 'chcon'

"/usr/lib/calamares/modules/mount/",line350, in run
mount_partition(root_mount, partition, partitions, mount_options, mount_options_list)

File &quote;/usr/lib/calamares/modules/mount/", line 240; in mount_partition[‘chcon’, ‘-reference-’ + raw_mount_point, mount_point])

File "/usr/lib/python3.10/", line 345, in call
with Popen(*popenargs, **kwargs) as p:

File "/usr/lib/python3.10/", line 971, in init
self._execute_child(args, executable, preexec_fn, close_fds,

File &quot/usr/lib/python3.10/", line 1847, in _execute_child
raise child_exception_type(errno_num, err_msg, err_filename)

Oh heck, the bit at the top is not exactly what I typed. Everything after Traceback looks mostly right.

I redid my usb stick with ventoy, and it worked.

For anyone else with a similar problem, here is what chat gpt gave me to troubleshoot. Consider the source, and get a second opinion.

It seems that the error message you’re receiving is related to a problem with the chcon command, which is used to change the SELinux context of a file or directory.

An “Input/output error” usually indicates a hardware issue, such as a faulty hard drive or a damaged file system. It’s also possible that the error is caused by a software issue, such as a corrupted installation image or a bug in the installer.

Here are a few steps you can take to troubleshoot the issue:

Check your hardware: Run a diagnostic test on your hard drive to see if there are any errors. You can do this by booting into a live CD or USB drive and running a disk utility such as GParted or Disk Utility. If you find any errors, you may need to replace your hard drive.

Verify the installation image: Check the SHA256 hash of your installation image to ensure it was downloaded correctly and is not corrupted. You can use a tool such as sha256sum to do this.

Try a different installation method: If the error persists, try installing EndeavourOS using a different method, such as a different USB drive or a different installation medium altogether.

Disable SELinux: If all else fails, you can try disabling SELinux during the installation process. To do this, boot into the live CD or USB drive, open a terminal, and run the command "setenforce 0" to temporarily disable SELinux. Then, run the installer again and see if the error persists.

If none of these steps work, you may need to seek additional help from the EndeavourOS community or the Arch Linux forums.