Install EndeavourOS on MacBook Pro 2007

Hi,

I am trying to install EndeavourOS on MacBook Pro 2007 (A1226)
I was able successfully install it from USB, at least it said “Successfully Installed”
but after rebooting it does not start.

Stopped on load screen saying

Starting version 249.7-2-arch
/dev/sda2/: clean, 213691/6558400, 1824455/270187 blocks
-

Any idea what is next?

Did you try nomodeset as a kernel parameter on boot?

Welcome to the forum @onesign :partying_face::tada::balloon:

Yes … Welcome. :slightly_smiling_face:

A buddy of mine also gifted me a 2007 Macbook. . . it was a half year though. Some of them are unfortunately 32 bit. I had to install Debian/Sparky/MX on it.

This was my EXACT same scenario when I tried EOS on it.

1 Like

Just tried, it goes a bit more but still black screen with blinking cursor

Your model has a 64-bit processor but a 32-bit EFI boot. It is possible to run a 64-bit distro on those machines, it even will be recognised as a64-bit machine when running.

Just follow this website and it will run on your machine. (It was a very long time I used it, but I was able to run any 64-bit distro on my, now deceased, MacBook Pro 2006.

4 Likes