Install deepin desktop next to plasma desktop

I’m running the plasma desktop and want to install deepin desktop as a second desktop. I’ve installed the deepin and deepin-extra packages and switched the desktop manager to lightdm. After reboot there is no option to select the deepin desktop. Is there a guide where you can see how to install an extra desktop environment?

What LightDM greeter are you using?

I have switch to the lightdm through the welcome app. I don’t know what greeter is used. Is setting the lightdm desktop manager in the welcome app not enough?

You’re probably using the gtk-greeter then.

On the top bar, there should be a button that will have the logo of your desktop environment (in your case it should be the kde logo) Click on that and you can change to deepin from the menu

Edit: No need to restart your pc for this. Simply logout to access this screen.

I only get the option to switch between Gnome/Gnome on Xorg or Plasma. There is no deepin option.

I’m using lightdm with slick greeter and upon installing deepin package I get the deepin option at login.

If I try to install both deepin and deepin-extra, then I get the error

error: failed to commit transaction (conflicting files)
/usr/bin/deepin-screenshot exists in both 'deepin-screen-recorder' and 'deepin-screenshot'
Errors occurred, no packages were upgraded.
error installing repo packages

Are you sure that deepin was installed correctly?

Edit: The relevant bug report :
And a recent post from this forum Error while updating (/usr/bin/deepin-screenshot exists in filesystem)

1 Like

I only got this error with the deepin-extra package. The deepin package installed without any errors.

You only get the error when you installe the deepin-screen-recorder package. I installed al the other packages and now you can select the deepin desktop. Thanks for all the replies.


hm seems the package group is still not fixed then… we do change from the group to a list to solve this on installer…