[INFO] Kernel modules fail to load after update when using optimus-manager

straight to the point:
in this thread i suspected that reason of my OS breaks is optimus manager, it had been 3 times, so i said why not, im gonna test 2-3 times more in different environments for the sake of science.
here’s my laptop spec :

Ram : 16GB 2400mhz
CPU : core i5-6200u with intel HD 520 iGPU
GPU: nvidia gtx 940 4GB, GDDR5 version

everytime i installed OS, i thought “lets use nvidia as default cuz im too lazy to switch before gaming, not worth of logging out” so i created below config in this directory /etc/optimus-manager/optimus-manager.conf

[optimus]
startup_mode=nvidia
startup_auto_battery_mode=nvidia
startup_auto_extpower_mode=nvidia

with this config, everything works well except sudo pacman -Syu , i didnt notice any error while updating but just after rebooting system, every single time i was encountering this :


i’ve created a thread in forum about this problem but didn’t find any real solution so everytime i had to clean install OS.
this time i did everything i was doing before, except creating that config, updated my OS few times and didn’t see any problems so yeah, i guess thats it

idk if my conclusion is correct about optimus or not, i’d be happy if u help me in case i’m wrong

The first thing you should do is look in the logs and see which module is failing to load and what the error is.

Also, is there a reason you are using a custom kernel? It seems more likely that a custom kernel would be causing a module not to load than it being optimus manager but it is hard to say without the logs.

1 Like

more infos about logs in this thread

also i havent tried any custom kernels to this day, using the default one ships with EOS

I don’t see any relevant logs in that topic.

We need to see the logs of where the kernel modules are failing to load.

The title of this topic is “[INFO] optimus with nvidia breaks OS after kernel compiling”

What “kernel compiling” are you doing?

You are getting far enough in the boot process that this shouldn’t require a re-install. It looks to me like you have a partially working system at that point.

There are multiple places where you can be dropped into maintenance mode. Here it seem to be happening late enough that you have a viable system.

1 Like

sorry, i thought that thread is enough, but i can re-produce that situation if its necessary for studying on it

by kernel compiling i meant this :

at that point, i tried :

  • uninstalling nvidia and booting w/o it
  • reinstalling kernel
  • trying zen kernel with and w/o nvidia

but nothing worked so i had to reinstall to get a fully working OS since i had to do my work

That is not kernel compiling. That is your initramfs being built by the mkinitcpio hook.

In one of your other topics you say this:

after installing this package, i create a custom config to run nvidia on boot,

Can you describe specifically what you are doing there? Which files are you editing?

Also, how are you installing optimus-manager?

2 Likes

thanks for the info!

by config i meant what i wrote in first post, the custom entry(?) for optimus-manager
and i install it through yay

OK, well, it is hard to diagnose without the logs.

If you ever get in that situation again, please get the logs of where the module(s) are failing to load.

Also, just for future reference, that is likely not that hard to fix from that position. You are deep enough in the boot process where you could remove optimus-manager if you think that is the problem.

Lastly, I am going to edit the title of this topic to be a bit more representative of the actual issue here.

3 Likes

if it helps the community, i’ll install EOS on another partition and reproduce that errors
also, removing optimus-manager didn’t work
thanks for the editing title :smiley: