Inconsistent cursor theming in KDE (in gtk applications and on sddm) [SOLVED]

I see that the cursor theme on sddm is the adwaita theme rather than the breeze cursor that was selected, and that the cursor when using gtk applications like firefox changes from the breeze theme to a different, black, older looking cursor when right clicking certain elements like the favorites bar. To resolve these issues, I went into sddm settings (Settings → Startup and Shutdown → Apply Plasma Settings), which fixed the issue with sddm. For the issue with gtk application cursors, I followed this reddit thread,, which suggested that I edit /usr/share/icons/default/index.theme, and change Inherits=(somethingelse) to Inherits=breeze_cursors.

i do not have such issue here on a fresh plasma install also /usr/share/icons/default/index.theme is set to adwaita I have plasma settings for GTK set to breeze (default) no need to set anything else to have breeze used everywhere…
same for sddm… may because I changed settings on both parts what applies these settings ?
Can someone reproduce the issue?

Are you running Wayland in this install? I’ve updated my draft KDE wiki entry and included this issue - see here Proposed KDE Plasma entry for the Wiki - #14 by r0ckhopper

just checked on an untouched install (using X11) in VM and I do not see this issue there sddm and over gtk apps it uses breeze cursor.

On a fresh EndeavourOS KDE install running Wayland, the Breeze cursor is used everywhere except SDDM and the EOS apps. Clicking “Apply Plasma Settings…” in Settings > Startup and Shutdown > Login Screen (SDDM) fixes the SDDM cursor to Breeze. But for the EOS apps, editing /usr/share/icons/default/index.theme is required. All other GTK apps show the Breeze cursor.

if so nothing we can do about… as we do not enable wayland session per default… changing from X11 to wayland causes needed changes on plasma… it seems it does not change this stuff automatically… (like almost everything else)

I will check if it is the same if I install wayland per default and not starting a X11 session before that…

non systemwide will work too:

1 Like

we could workaround this in the next release with fixes for DEs but as long as DE is installed unconfigured… we can not do anything .

1 Like

I am in fact running wayland, so I suppose that must be why.

Yes. that’s why.

Since Wayland is not the default yet for Plasma, it’s probably OK for now to just cover this in the forthcoming Wiki article.

1 Like