Inability to install system, lack of WiFi drivers

Hello, I wanted to install this distribution, but tried to do that with my Surface Pro 6. I couldn’t do that. Lack of marvell WiFi drivers didn’t gave me a chance to install this with KDE Plasma, because it is have to have WiFi connection. Guys, could you add linux-firmware-marvell and linux-firmware-whence to your distro :)?

If you are still interested to give the online install a shot, you could try usb-tethering the internet connection of your mobile phone if that is possible.

More, you could add the packages you need to have in the installed system to user_pkglis.txt in the home directory of the liveuser.

Thanks for answer, I couldn’t connect to phone HotSpot, because LiveUSB can’t see any WiFi spots. Userpkg list is good, but problem is not that I can’t connect WiFi after install (then I can connect my phone to USB port and install firmware-marvell manually), problem is I can’t connect to WiFi in Live USB. In LiveUSB i can’t install drivers manually because it need reboot. But I can’t reboot driver because LiveUSB. A vicious circle :slight_smile:

Download and save firmware packages to the EndeavourOS USB, problem solved :grin:

No, problem is not solved, because to apply this drivers I need to reboot, log out, or something else doesn’t help :slight_smile:

Perhaps you could do an offline install.

Then once booted to your installed system, connect your phone to the usb port and use its internet connection to install the required packages.

When you got WiFi up and running, you could install KDE and remove Xfce.
Perhaps the more convenient way would be to create a new user for the “KDE Plasma user”.

See the following articles for how to install and/or remove a desktop environment:

Please have a look at this post as well:

Packages can be installed to a live system. After installation you can manually insert driver with modprobe command instead of rebooting, unless another driver is assigned.

1 Like

Some basic WiFi driver is assigned => (as you said) I can’t apply new driver. lspci -k showed that

So, developers. If you read that, I would you like to add linux-firmware-marvell and linux-fimware-whence packages into distribution. Sorry if some phrases are a bit rude, English is not my native language :grin::grin:

This is different to

as it uses a USB cable.

Given there are several workarounds here I’m not sure it’s necessary to add firmware for every niche piece of hardware?

Perhaps open a thread to try to get this working?

1 Like

But I think that it is correct. Basic arch offers drivers for my device and I install it without problems. Why your distro that is based on it should not offer that?

linux-firmware-whence is already installed because it is a dependency of linux-firmware. So you need the marvell firmware package for the WiFi. You could download it to a usb and then install it after.

Okey, guys, thanks for your answer. I understood what USB tethering is. Maybe it is solution, but can’t test as I have not 1 → 2 USB dongle. But I think that one package is not a problem for Distro ISO. Maybe will test this variant after. Big thanks for your help :grin:

Total Installed Size: 47,37 MiB
Not huge but how to decide what to include and what not ?

core/linux-firmware-whence 20220708.be7798e-1 (28.6 KiB 184.5 KiB) (Installed)
    Firmware files for Linux - contains the WHENCE license file which documents the vendor license details
core/linux-firmware-qlogic 20220708.be7798e-1 (10.7 MiB 10.7 MiB) 
    Firmware files for Linux - qlogic / Firmware for QLogic devices
core/linux-firmware-qcom 20220708.be7798e-1 (23.3 MiB 23.3 MiB) 
    Firmware files for Linux - qcom / Firmware for Qualcomm SoCs
core/linux-firmware-nfp 20220708.be7798e-1 (4.4 MiB 4.4 MiB) 
    Firmware files for Linux - nfp / Firmware for Netronome Flow Processors
core/linux-firmware-mellanox 20220708.be7798e-1 (57.6 MiB 57.6 MiB) 
    Firmware files for Linux - mellanox / Firmware for Mellanox Spectrum switches
core/linux-firmware-marvell 20220708.be7798e-1 (46.0 MiB 47.4 MiB) 
    Firmware files for Linux - marvell / Firmware for Marvell devices
core/linux-firmware-liquidio 20220708.be7798e-1 (15.6 MiB 15.6 MiB) 
    Firmware files for Linux - liquidio / Firmware for Cavium LiquidIO server adapters
core/linux-firmware-bnx2x 20220708.be7798e-1 (2.3 MiB 2.3 MiB) 
    Firmware files for Linux - bnx2x / Firmware for Broadcom NetXtreme II 10Gb ethernet adapters

We had the discussion after the change on arch splitting the firmwares …
Could be that it makes sense to add marvell ?

It seems that marvell drivers are needed for surface laptops

and they are hitting the second market hard :wink:

linux-firmware-whence is a dependency of linux-firmware-marvell which is already installed.

but … linux-firmware-marvell is not a dependency of anything and not installed on the ISO… and if the wifi device is internal and not pluggable the firmware needs to be present on bootup to enable the device.
Afaik –

Okay…I read it wrong maybe?




Edit: But why do they have a bunch of separate firmware for surface pro? Other firmware for other hardware?

linux-firmware-whence is already in the iso,

We just need to add linux-firmware-marvell.