IdeaPad Gaming 3i 16" (12th Gen 12700H, 3050 Ti)

You could also post the link for these to see if it shows us anything

sudo dmesg | eos-sendlog
journalctl -b -0 | eos-sendlog

Please try installing the rtw88-dkms-git package as it seems the chip is probably the 8852 BE since the id shows 8852 and the Lenovo site is showing one of these chips.

  • RTL8822CE-2024.0.8.134, 8852BE-6001.0.15.111
yay -S rtw88-dkms-git

Edit2: It may or may not work as 8852BE isn’t even listed anywhere? But no harm in trying. If it doesn’t work you can just uninstall it.


I still think this is a newer Realtek chip and it should be loading rtw89_pci as the kernel module. So if after trying the stuff in the above posts and nothing works. Make sure the AUR packages are uninstalled and if you also tried the lts kernel.

You could try this after removing the AUR packages

sudo modprobe rtw89_pci

dmesg output
journalctl -b -0 output

1 Like

could you clarify a few things here?
I’m on LTS, but i dont see a difference. What is a sure-fire way to check if wireless is working? the applet on xfce looks like it would only show LAN anyway.
Assuming that indeed it still does not work, how do I remove the AUR packages? i just mean, which ones such that Im not bricking anything…
Then Ill try that command you are suggesting

Did you remove the first AUR package before installing the other one? yay -R rtw89-dkms-git Then if you installed the other one after it would be yay -R rtw88-dkms-git.

Edit: You should only be installing one thing and checking and then remove it if it doesn’t work so you are back to square one and you know where you are at.

Edit2: You can check the network hardware with

inixi -Na

Edit: Post the ouput
Edi2: Having the lts kernel installed is okay you don’t have to worry about removing that just the module packages i was referring to.

What does this show


Edit: I’m only seeing the Bluetooth rtl8852bu in the logs. So WiFi is not being recognized and or loaded. as far as i can tell.



lspci -v | grep -i net

show anything?

1 Like

You could also update the pciids.

sudo update-pciids
1 Like

sure. So rfkill is something i came across when doing tlp affairs, it’s why stuff is blocked. Anyway, i see this;

$ rfkill
ID TYPE      DEVICE                 SOFT      HARD
 0 wlan      ideapad_wlan      unblocked unblocked
 1 bluetooth ideapad_bluetooth   blocked unblocked
 3 bluetooth hci0                blocked unblocked

output of inxi -Na:

for somereason, now, when doing yay -S rtw89-dkms-git (and letting it go through) i get these lines at the end (copying only last few lines):

 ning post-transaction hooks...
(1/3) Arming ConditionNeedsUpdate...
(2/3) Install DKMS modules
==> dkms install --no-depmod rtw89/r178.f3ea327 -k 5.15.52-1-lts
/usr/bin/dkms: line 1033: sha512: command not found
/usr/bin/dkms: line 1033: sha512: command not found
==> depmod 5.15.52-1-lts
(3/3) Checking which packages need to be rebuilt

Try this command

rfkill unblock all

Did you reboot after installing rtw89-dkms-git?

This is an upstream bug which, seemingly, is still not fixed:

Try these modprobe commands

sudo modprobe -rv rtw_8852ae
sudo modprobe -v rtw_8852ae

I’m still reading and thinking. As i said before I’m pretty sure the latest kernels have the rtw89_pci module for the 8852AE chip. You shouldn’t need to use the AUR package rtw89-dkms-git as far as i know.

If you remove the AUR package. Maybe try these.

sudo modprobe -rv rtw_8852ae
sudo modprobe rtw89_pci

Perhaps @elakpa would need to switch to the latest kernel then?

indeed, trying modprobe i find that i do not have rtw89_pci

1 Like

You have the latest kernel installed, don’t you?
Just reboot and choose that one.
Once logged in, try again the command lines given by @ricklinux.

1 Like

first didnt work. but the second, once in “linux” kernel (i assume it’s just the latest) returned no output. i have rebooted, with higher hopes, but nothign seems to have changed. inxi -Na shows:

  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Lenovo driver: r8169 v: kernel port: 4000 bus-ID: 0000:2f:00.0
    chip-ID: 10ec:8168 class-ID: 0200
  Device-2: Realtek vendor: Lenovo driver: N/A port: 3000
    bus-ID: 0000:30:00.0 chip-ID: 10ec:b852 class-ID: 0280
1 Like

Can you try the default kernel?
LTS kernel might not be new enough…