I3wm started picom automatic also it is commented?

Hi, I’ll go straight to the point. i3wm started to show animation when switching work space which is very annoying and slow. Do anybody has any idea of what’s going on?

1 Like

I’m guessing its picom (compositor). check your ~/.config/i3/config to disable picom completely by commenting it out, or change or ~/.config/picom.conf to disable fading

changes saved to picom.conf will update instantly, but if you decide to disable picom completely in i3 config, you can type “pkill picom” in your terminal to end it

yes i think it is caused by the fact that picom now starts automatically as they add /etc/xdg/autostart for it to the package… and i3 setup using dex that reads this files… so you will need to remove the package if you do not want to use picom, or set it up to not use the defaults by adding a config under
~/.config/picom.conf you should have an example there:
~/.config/example.picom.conf you can use:
cp ~/.config/example.picom.conf ~/.config/picom.conf

see here:
2022-11-20_13-40
https://archlinux.org/packages/community/x86_64/picom/

1 Like

Were you able to fix this, OP? I am having the same issue. I don’t have a picom.conf file in my ~/.config I’ve only got an example.picom.conf and I have changed fading and opacity to 1.0 and I still get the fading. Not sure why it’s not working.

cp ~/.config/example.picom.conf ~/.config/picom.conf
example file is … an example only picom will not us it it reads only default path for the config…

so you need to copy / rename the file … to ~/.config/picom.conf`

if me. rename your picom.conf in ~/.config

cp picom.conf from /etc/xdg to ~/.config ( play with that one ) when finisih kill picom then restart it .

That just me

EDit… forgive . i no use EOS ATM , i check eos github ( example.picom.conf ) look same … :pray:

1 Like

That was the solution! I forgot to check the picom.conf in /etc/xdg/ I changed it in there and it works like a charm now. Thank you!

yea but I think caused by your post it would may be less confusing and less to maintain if w would not ship that file and only hint on how to copy it from what the package ships to users config…

1 Like

you no change in there . should cp to ~/.config
then( " chown - change file owner " ) that the file should change …

EDit… At end of day it " Your system , your rule " happy you fix it :+1:

Thanks everybody for the help. Here it’s how I fixed it:

mv cp ~/.config/example.picom.conf ~/.config/picom.conf

Inside picom.conf I changed fading to false