I3wm Spotify launching to blank screen

I’m super new to Linux, been learning for less than a week, and I’ve been having a lot of issues with the distros & DEs I’ve been picking. So far for EOS I’ve had way less issues, but I haven’t been able to get anything I download fully working, there’s always some issue with it when I launch after a (seemingly) clean download. After being unable to launch Notion, and Discord and Chromium being frozen on one screen thought I had maybe done something wrong in the actual OS download process, so I did a fresh install, but I’m still having issues. I haven’t tried downloading any of those apps again, this time I tried Spotify first, and I’ve tried installing it through yay and doing it manually with makepkg, but I’m getting the same outcome.

Actual issue: Spotify installs with no issues; when launched through the app launcher it either flickers on the login screen or is stuck on a blank gray/black screen, when launched through terminal it does the same and says this:

[gwenyth@endeavour-xps9320 ~]$ spotify
spotify: /usr/lib/libcurl-gnutls.so.4: no version information available (required by spotify)
/opt/spotify/spotify: /usr/lib/libcurl-gnutls.so.4: no version information available (required by /opt/spotify/spotify)
/opt/spotify/spotify: /usr/lib/libcurl-gnutls.so.4: no version information available (required by /opt/spotify/spotify)
/proc/self/exe: /usr/lib/libcurl-gnutls.so.4: no version information available (required by /proc/self/exe)

Any help would be appreciated, thank you!!

*Edit with logs:

Output of inxi -Fxxc0z --no-host | eos-sendlog is https://clbin.com/cNKnL
Output of journalctl -b -0 | eos-sendlog is https://clbin.com/pTzAm
Please let me know if you need more!

You could try to install libcurl-gnutls and if that doesn’t work because it’s already installed replace libcurl-gnutls with libcurl3-gnutls.

See the comments for this AUR package here

Welcome to the forum @whispy :enos: :enos_flag: :partying_face:

Hi! Installing libcurl3-gnutls did stop the commands, but Spotify still doesn’t work :smiling_face_with_tear:

Thank you!! :two_hearts: :blush:

Could it be that there might be some other underlying issue with your specific hardware + os combination and not an issue with a particular application?

You might want to open a new thread and post some info about your system:


Thank you! I edited the post with the main 2 that link recommends

1 Like

If anyone else ever has this issue, launching Spotify in terminal with --disable-gpu or adding it to the exec line in the .desktop file for Spotify solved my issue! The issue has something to do with hardware acceleration, as disabling it on every app seems to work so far.

However, if you add --disable-gpu to the exec line it does not work when launched from terminal unless you type it there as well, otherwise just use the app launcher :blush:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.