I3wm help about workspaces and screen resolution

So, I have a few questions about i3 config of endaevouros.

There seem to be only three workspaces 2,3,4
I can’t switch to 1,5-9,0 by using $mod + 1,5-9

And also, I have used a lesser resolution 1600x1900 as the default is 1080p i.e 1920x1080
but everything still looks small like in firefox.
I have used archlabs i3 as well but there was no such resolution problem or switching workspaces problem.
Also, the keybindings in my keyboard for brightness control doesn’t work either.
Any help would be greatly appreciated.

Welcome aboard! @v3n0m

EndeavourOS i3 doesn’t use the default i3 config. There is more information here: https://endeavouros.com/docs/window-tiling-managers/i3-wm/

I know that but in the keybindings shortcut that endaevouros i3 has, there are 10 workspaces mentioned. From 0-9, but I get only three workspaces.

1 Like

Also, I’m experiencing quite much screen tearing.
Does endaevour os by default make configs for xorg etc, or use the default ones?

1 Like

I just started using i3 a few days ago. @joekamprad can you help here?

I just checked my dpi and its 97x97. Is it done directly by xorg or any configuration used by the endaevouros team?

1 Like

Sit tight and wait for @joekamprad. He is the dev that created EndeavourOS i3.

I solved that one by installing ‘xorg-xbacklight’ and adding following keybindings in my i3 config:

bindsym XF86MonBrightnessUp exec xbacklight -inc 10
bindsym XF86MonBrightnessDown exec xbacklight -dec 10

you might want to check in here (since it’s the source I used to solve my problem):

look for the folowing entry in your i3 config file:

#switch to workspace
bindsym $mod+2 workspace $ws2
bindsym $mod+3 workspace $ws3
bindsym $mod+4 workspace $ws4

#move focused container to workspace
bindsym $mod+2 move container to workspace $ws2
bindsym $mod+3 move container to workspace $ws3
bindsym $mod+4 move container to workspace $ws4

as you can see by default only workspace 2-4 are mentioned here.
If you want the other ones, you can manually add the others here… (just copy the line in your config and change the numbers.

you will have to reload i3 for these changes to have effect

This is possibly a problem with the compositor, but I’ll leave that one up for @joekamprad


we do not set any configs for GPU per default, compositor for i3 can be changed (and needs to be changed to fit your gpu)

default setup:
exec --no-startup-id xcompmgr -c
but you could also use picom and change whatever is better working for your gpu.

Tearing is most likely a setting needed for the GPU driver in use, different for each one…


I’ve noticed that using picom mostly solved the tearing on my old Dell with Intel graphics.
Didn’t want to make any blind recommendations though, since I don’t really know the technical details of those compositors…

I know there’s also compton, but haven’t even tried that one

1 Like

picom replaced compton. :+1:
picom 8.1-2
Package Actions
Source Files / View Changes
Bug Reports / Add New Bug
Search Wiki
Security Issues
Flag Package Out-of-Date (?)
Download From Mirror
Architecture: x86_64
Repository: Community
Description: X compositor that may fix tearing issues
Upstream URL: https://github.com/yshui/picom
License(s): MIT, MPL
Provides: compton
Replaces: compton
Conflicts: compton
Maintainers: Alexander Rødseth
Package Size: 150.2 KB
Installed Size: 374.5 KB
Last Packager: Alexander Rødseth
Build Date: 2020-09-29 14:22 UTC
Signed By: Alexander Rødseth
Signature Date: 2020-09-29 14:22 UTC
Last Updated: 2020-09-29 14:25 UTC

1 Like

Aha! no point in replacing picom then :slight_smile:

1 Like

for picom (fka compton) you can find options and configs for different GPU 's and drivers…

xcompmgr is very minimal on the way you can configure (see: xcompmgr --help )


I’m reading up on it now :point_up_2:

seems like there is a lot more to it than i initially knew :slight_smile:

1 Like

linux is a rabbit hole in some ways :wink:

#exec --no-startup-id xcompmgr -c
exec --no-startup-id picom -cC



Applies to fully maximized windows (in sessions without any panels) with the default picom.conf caused and resolved by the following option:

unredir-if-possible = false;


Isn’t that what makes it appealing to us tinkerers? :upside_down_face:


Always have bookmark ready :wink: It very helpful

1 Like