I3 welcome screen missing

Hello there. I have installed the i3wm version of EOS in VirtualBox to test it out, but I can’t seem to get the welcome screen upon first boot or any subsequent reboot. When I press Super+d to get the rofi menu and select Welcome, nothing happens. In the terminal, when I type eos-welcome, I get a message saying that it is disabled and that I should use --enable. But when I add the flag, the same message appears. Is there a bug in the latest release or am I missing something? Again, this is a fresh install. Thank you in advance for the help!

using the latest release?

Yes. Downloaded the iso this morning, and updated the mirrors before installing.

From? can you post a link?

From https://endeavouros.com/latest-release/, specifically the link from Github (Worldwide) – Torrent

or give install log :wink:

cat /var/log/endeavour-install.log | eos-sendlog

You mean this https://clbin.com/4FSCD ? I hope that’s correct.

yes… but installation looks fine…
do you have theming and setup from EndeavourOS like so:

Yes. As I said, the install is fresh. Firefox autostarts fine. There’s just no welcome screen autostarting, and I can’t open it manually.

it should start, i just done a testinstall …
what shows cat ~/.config/i3/.config | grep welcome ?
cat ~/.config/i3/.config | grep dex

Here is the output for “welcome”:

# if enabled you should comment welcome app.
# start welcome app
exec --no-startup-id sh /usr/share/endeavouros/scripts/welcome --startdelay=3

And here is the output for dex:

# dex execute .desktop files
# in this cases better disable dex and use manual starting apps using xdg/autostart
#exec --no-startup-id dex -a -s /etc/xdg/autostart/:~/.config/autostart
exec --no-startup-id dex --autostart --environment i3

what if you comment the #exec --no-startup-id sh /usr/share/endeavouros/scripts/welcome --startdelay=3
line in config?

1 Like

I can confirm this bug. Commenting out the delay makes no difference.

exec --no-startup-id dex --autostart --environment i3
is the latest change on the config…
but I have no such issue here welcome starts just fine for me …

The only thing I see is that dex is enabled and welcome has a starter that starts it manually.
it is not the delay I say to comment the starter completely must be commented.
welcome should start automatic from /etc/xdg/autostart if dex is running

you could try to use the default dex starter and comment the one used:
exec --no-startup-id dex -a -s /etc/xdg/autostart/:~/.config/autostart
#exec --no-startup-id dex --autostart --environment i3
and indeed comment the welcome starter line:
#exec --no-startup-id sh /usr/share/endeavouros/scripts/welcome --startdelay=3


i got two welcomes if i have dex running and the starter enabled in config…

and also no issue disable enable welcome:

Well thank goodness! I thought I had done something wrong. Even though I’ve been using Linux for a year and a half or so, there are still many things I have to learn. Installing a distro in VirtualBox is new to me. So I’m glad I wasn’t the only one to see this.

Anyway, I tried joekamprad’s solution but it didn’t make any difference. So I reinstalled the distro, having updated the mirrors just prior, and now the welcome screen appears after boot! I checked the github page, and I see a change related to the welcome screen. Perhaps that did the trick?

Thanks all for the help!

ah ha :wink: so system was not fully updated before? could have been that.